summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2019-12-15 19:43:38 +0300
committerAnton Kudelin2019-12-15 19:43:38 +0300
commitf2f694fd0bfa0192fb07d6d78d5d30ac0f672c38 (patch)
treef1c3b6e4791aa77484c1140ba6bc600715060b7d
parent36371bc87832ad1c276abf55eedc3fdb7070ba5d (diff)
downloadaur-f2f694fd0bfa0192fb07d6d78d5d30ac0f672c38.tar.gz
Cleaned up a bit, updated dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD56
2 files changed, 21 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a06a58734332..80c8e6f43033 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = plasma5-applets-plasma-pstate
pkgdesc = Intel P-state and CPUFreq Manager Widget
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jsalatas/plasma-pstate
arch = any
- license = GPL v2
+ license = GPL2
+ makedepends = sed
depends = plasma-workspace
optdepends = libsmbios: Dell's Thermal Management Feature
- optdepends = x86_energy_perf_policy: If your processor doesn't support EPP (ie older generations without HWP)
+ optdepends = x86_energy_perf_policy: If your processor doesn't support EPP i.e. older generations without HWP
source = https://github.com/jsalatas/plasma-pstate/archive/1.0.6.tar.gz
sha256sums = b2abb03e9fe939fd6f516b8e65ef0badad2558c0b55687dd044756523e3900dc
diff --git a/PKGBUILD b/PKGBUILD
index a44d482ecfa6..3bfa2d71ed9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,32 @@
-# Maintainer: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
+# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Contributor: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
_applet_name=plasma-pstate
pkgname=plasma5-applets-${_applet_name}
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="Intel P-state and CPUFreq Manager Widget"
url="https://github.com/jsalatas/${_applet_name}"
arch=('any')
-license=('GPL v2')
+license=('GPL2')
depends=('plasma-workspace')
-optdepends=(
- "libsmbios: Dell's Thermal Management Feature"
- "x86_energy_perf_policy: If your processor doesn't support EPP (ie older generations without HWP)"
-)
+makedepends=('sed')
+optdepends=("libsmbios: Dell's Thermal Management Feature"
+ "x86_energy_perf_policy: If your processor doesn't support EPP i.e. older generations without HWP")
source=("https://github.com/jsalatas/${_applet_name}/archive/${pkgver}.tar.gz")
sha256sums=('b2abb03e9fe939fd6f516b8e65ef0badad2558c0b55687dd044756523e3900dc')
package() {
- cd "${srcdir}/${_applet_name}-${pkgver}"
+ cd $srcdir/$_applet_name-$pkgver
- _plasmoid_dir="${pkgdir}/usr/share/plasma/plasmoids"
- mkdir -p "${_plasmoid_dir}"
- cp -r "gr.ictpro.jsalatas.plasma.pstate" "${_plasmoid_dir}"
+ _plasmoid_dir=$pkgdir/usr/share/plasma/plasmoids
+ mkdir -p $_plasmoid_dir
+ cp -r "gr.ictpro.jsalatas.plasma.pstate" $_plasmoid_dir
- _sudoers_dir="${pkgdir}/etc/sudoers.d"
- mkdir -p "${_sudoers_dir}"
- chmod 750 "${_sudoers_dir}"
- install 99-plasma-pstate "${_sudoers_dir}"
- sed -i 's/sudo/wheel/' "${_sudoers_dir}/99-plasma-pstate"
- chmod 400 "${_sudoers_dir}/99-plasma-pstate"
+ _sudoers_dir=$pkgdir/etc/sudoers.d
+ mkdir -p $_sudoers_dir
+ chmod 750 $_sudoers_dir
+ install 99-plasma-pstate $_sudoers_dir
+ sed -i 's/sudo/wheel/' $_sudoers_dir/99-plasma-pstate
+ chmod 400 $_sudoers_dir/99-plasma-pstate
}
-
-# SUDOERS_FILE="99-plasma-pstate"
-#
-# cp -R ${SUDOERS_FILE} /etc/sudoers.d/
-# plasmapkg2 -t plasmoid -g -i gr.ictpro.jsalatas.plasma.pstate
-#
-# chmod 755 /usr/share/plasma/plasmoids/gr.ictpro.jsalatas.plasma.pstate/contents/code/set_prefs.sh
-#
-# chown root:root /etc/sudoers.d/${SUDOERS_FILE}
-# chmod 400 /etc/sudoers.d/${SUDOERS_FILE}
-#
-# # Test for wheel group instead of sudo
-# # this is the case of arch based distros
-# wheelgroup=`grep wheel /etc/group | wc -l`
-# sudogroup=`grep sudo /etc/group | wc -l`
-# if [ "$wheelgroup" -eq "1" ] && [ "$sudogroup" -eq "0" ]; then
-# # seems to be safe enough: there is a wheel group and not a sudo group
-# sed -i 's/sudo/wheel/' /etc/sudoers.d/${SUDOERS_FILE}
-# fi
-#
-# echo -e "\nSetup complete."
-# exit 0