summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-10-16 17:42:19 +0200
committerStephan Springer2018-10-16 17:42:19 +0200
commit26af2581b8b6356ddb6f50c08ee44014bcda348e (patch)
treed6247f48812a5963d51ed6c57d7ba78941ea5a27
parentbe05b6f219b5b26780de6f76d5f45203cc710deb (diff)
downloadaur-26af2581b8b6356ddb6f50c08ee44014bcda348e.tar.gz
adopt; integrate CMakeLists.txt; use SHA256
-rw-r--r--.SRCINFO8
-rw-r--r--CMakeLists.txt15
-rw-r--r--PKGBUILD38
3 files changed, 39 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9107e6a0da8a..e16269afbad2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,10 +8,10 @@ pkgbase = plasma5-applets-todolist
makedepends = extra-cmake-modules
depends = plasma-workspace
depends = qt5-declarative
- source = https://github.com/Zren/plasma-applet-todolist/archive/v7.tar.gz
- source = https://gitlab.com/kikadf/patches/raw/master/plasma5-applets-todolist/Add_CMakeLists.patch
- md5sums = d79af3b345f3e798b0f3e0210c465639
- md5sums = 3881942579d0e79c4e1e78ae570cbcd9
+ source = plasma5-applets-todolist-7.tar.gz::https://github.com/Zren/plasma-applet-todolist/archive/v7.tar.gz
+ source = CMakeLists.txt
+ sha256sums = e064a4aebd1eca2444b0178b19b55890f6e5eda7dabf55cc4ef099fdc4c0d0e7
+ sha256sums = SKIP
pkgname = plasma5-applets-todolist
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..f6856ef5dd95
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Set minimum CMake version (required for CMake 3.0 or later)
+cmake_minimum_required(VERSION 2.8.12)
+
+# Use Extra CMake Modules (ECM) for common functionality.
+# See http://api.kde.org/ecm/manual/ecm.7.html
+# and http://api.kde.org/ecm/manual/ecm-kde-modules.7.html
+find_package(ECM REQUIRED NO_MODULE)
+# Needed by find_package(KF5Plasma) below.
+set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${CMAKE_MODULE_PATH})
+
+# Locate plasma_install_package macro.
+find_package(KF5Plasma REQUIRED)
+
+# Add installatation target ("make install").
+plasma_install_package(package com.github.zren.todolist)
diff --git a/PKGBUILD b/PKGBUILD
index cf350e7a6f8a..31f5da7b01a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: kikadf <kikadf.01@gmail.com>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: kikadf <kikadf.01@gmail.com>
+_pkgname=plasma-applet-todolist
pkgname=plasma5-applets-todolist
pkgver=7
pkgrel=1
pkgdesc="Extension of the kdeplasma-applets notes widget, where it's organized as a list"
-url="https://github.com/Zren/plasma-applet-todolist"
+url="https://github.com/Zren/$_pkgname"
license=(GPL)
depends=('plasma-workspace' 'qt5-declarative')
makedepends=('extra-cmake-modules')
arch=('any')
-source=(https://github.com/Zren/plasma-applet-todolist/archive/v$pkgver.tar.gz
- https://gitlab.com/kikadf/patches/raw/master/plasma5-applets-todolist/Add_CMakeLists.patch)
-md5sums=('d79af3b345f3e798b0f3e0210c465639'
- '3881942579d0e79c4e1e78ae570cbcd9')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Zren/$_pkgname/archive/v$pkgver.tar.gz"
+ 'CMakeLists.txt')
+sha256sums=('e064a4aebd1eca2444b0178b19b55890f6e5eda7dabf55cc4ef099fdc4c0d0e7'
+ 'SKIP')
prepare() {
- cd plasma-applet-todolist-$pkgver/todolist
- patch -p2 -i "${srcdir}"/Add_CMakeLists.patch
- rm -f build
- mkdir -p build
+ cd "$_pkgname-$pkgver"/todolist
+ cp "$srcdir"/CMakeLists.txt .
+ rm -rf build
+ mkdir -p build
}
build() {
- cd plasma-applet-todolist-$pkgver/todolist/build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cd "$_pkgname-$pkgver"/todolist/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
}
package() {
- cd plasma-applet-todolist-$pkgver/todolist/build
- make DESTDIR="$pkgdir" install
+ cd "$_pkgname-$pkgver"/todolist/build
+ make DESTDIR="$pkgdir" install
}