summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkikadf2016-08-26 18:50:24 +0200
committerkikadf2016-08-26 18:50:24 +0200
commitc58c0f5a46539b7b2c66cbd7b9cc8c6d62d207e9 (patch)
tree2ea62425c1dc78afd4479645f1ed26b9737dd0a8
downloadaur-c58c0f5a46539b7b2c66cbd7b9cc8c6d62d207e9.tar.gz
New package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..def58df562d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = plasma5-applets-todolist
+ pkgdesc = Extension of the kdeplasma-applets notes widget, where it's organized as a list
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/Zren/plasma-applets/tree/master/todolist
+ arch = any
+ license = GPL
+ makedepends = extra-cmake-modules
+ depends = plasma-workspace
+ depends = qt5-declarative
+ source = https://github.com/Zren/plasma-applets/archive/todolist-1.tar.gz
+ source = https://raw.githubusercontent.com/kikadf/patches/master/plasma5-applets-todolist/Add_CMakeLists.patch
+ md5sums = 5c4ab0a7f2d491652c712b5e963c63e2
+ md5sums = 3881942579d0e79c4e1e78ae570cbcd9
+
+pkgname = plasma5-applets-todolist
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00bcac636744
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: kikadf <kikadf.01@gmail.com>
+
+pkgname=plasma5-applets-todolist
+pkgver=1
+pkgrel=1
+pkgdesc="Extension of the kdeplasma-applets notes widget, where it's organized as a list"
+url="https://github.com/Zren/plasma-applets/tree/master/todolist"
+license=(GPL)
+depends=('plasma-workspace' 'qt5-declarative')
+makedepends=('extra-cmake-modules')
+arch=('any')
+source=(https://github.com/Zren/plasma-applets/archive/todolist-$pkgver.tar.gz
+ https://raw.githubusercontent.com/kikadf/patches/master/plasma5-applets-todolist/Add_CMakeLists.patch)
+md5sums=('5c4ab0a7f2d491652c712b5e963c63e2'
+ '3881942579d0e79c4e1e78ae570cbcd9')
+
+prepare() {
+ cd plasma-applets-todolist-$pkgver/todolist
+ patch -p2 -i "${srcdir}"/Add_CMakeLists.patch
+ rm -f build
+ mkdir -p build
+}
+
+build() {
+ cd plasma-applets-todolist-$pkgver/todolist/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+}
+
+package() {
+ cd plasma-applets-todolist-$pkgver/todolist/build
+ make DESTDIR="$pkgdir" install
+}