summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephan Springer2018-10-16 17:26:00 +0200
committerStephan Springer2018-10-16 17:26:00 +0200
commite00fa1d2d5567c3db4d4f33ccb16edcede18e8f6 (patch)
treebcfb44e8803dedb39171de14bcca00f728fe9abd
parentfad04ea7a71e20074607402609876b8afbf4979d (diff)
downloadaur-e00fa1d2d5567c3db4d4f33ccb16edcede18e8f6.tar.gz
adopt; integrate CMakeLists.txt; use SHA256
-rw-r--r--.SRCINFO8
-rw-r--r--CMakeLists.txt15
-rw-r--r--PKGBUILD38
3 files changed, 39 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e87035cfa0..76dd74e3f5ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,10 +9,10 @@ pkgbase = plasma5-applets-volumewin7mixer
depends = plasma-pa
depends = qt5-declarative
depends = python2
- source = https://github.com/Zren/plasma-applet-volumewin7mixer/archive/v23.tar.gz
- source = https://gitlab.com/kikadf/patches/raw/master/plasma5-applets-volumewin7mixer/Add_CMakeLists.patch
- md5sums = 99bf48315a4711db9bfd1b91c0cbf2e1
- md5sums = d8c46ebcd65232cb7a4d2a9c9621fb97
+ source = plasma5-applets-volumewin7mixer-23.tar.gz::https://github.com/Zren/plasma-applet-volumewin7mixer/archive/v23.tar.gz
+ source = CMakeLists.txt
+ sha256sums = 8f9430d9b8c4050a221f1ba2ae7cc557ccf5e4697366e6794d7024baf83a9ed0
+ sha256sums = SKIP
pkgname = plasma5-applets-volumewin7mixer
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 000000000000..35b11c770823
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+# Set minimum CMake version (required for CMake 3.0 or later)
+cmake_minimum_required(VERSION 2.8.12)
+
+# Use Extra CMake Modules (ECM) for common functionality.
+# See http://api.kde.org/ecm/manual/ecm.7.html
+# and http://api.kde.org/ecm/manual/ecm-kde-modules.7.html
+find_package(ECM REQUIRED NO_MODULE)
+# Needed by find_package(KF5Plasma) below.
+set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR} ${CMAKE_MODULE_PATH})
+
+# Locate plasma_install_package macro.
+find_package(KF5Plasma REQUIRED)
+
+# Add installatation target ("make install").
+plasma_install_package(package org.kde.plasma.volumewin7mixer)
diff --git a/PKGBUILD b/PKGBUILD
index 4e81dc7ebbe5..521a5ac9f009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: kikadf <kikadf.01@gmail.com>
+# Maintainer: Stephan Springer <buzo+arch@Lini.de>
+# Contributor: kikadf <kikadf.01@gmail.com>
+_pkgname=plasma-applet-volumewin7mixer
pkgname=plasma5-applets-volumewin7mixer
pkgver=23
pkgrel=1
pkgdesc="A fork of the default volume plasmoid with a Windows 7 theme (vertical sliders)"
arch=('any')
-url="https://github.com/Zren/plasma-applet-volumewin7mixer"
+url="https://github.com/Zren/$_pkgname"
license=(GPL)
depends=('plasma-pa' 'qt5-declarative' 'python2')
makedepends=('extra-cmake-modules')
-source=(https://github.com/Zren/plasma-applet-volumewin7mixer/archive/v$pkgver.tar.gz
- https://gitlab.com/kikadf/patches/raw/master/plasma5-applets-volumewin7mixer/Add_CMakeLists.patch)
-md5sums=('99bf48315a4711db9bfd1b91c0cbf2e1'
- 'd8c46ebcd65232cb7a4d2a9c9621fb97')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Zren/$_pkgname/archive/v$pkgver.tar.gz"
+ 'CMakeLists.txt')
+sha256sums=('8f9430d9b8c4050a221f1ba2ae7cc557ccf5e4697366e6794d7024baf83a9ed0'
+ 'SKIP')
prepare() {
- cd plasma-applet-volumewin7mixer-$pkgver
- patch -p1 -i ../Add_CMakeLists.patch
- rm -f build
- mkdir -p build
+ cd "$_pkgname-$pkgver"
+ cp "$srcdir"/CMakeLists.txt .
+ rm -rf build
+ mkdir -p build
}
build() {
- cd plasma-applet-volumewin7mixer-$pkgver/build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cd "$_pkgname-$pkgver"/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
}
package() {
- cd plasma-applet-volumewin7mixer-$pkgver/build
- make DESTDIR="$pkgdir" install
+ cd "$_pkgname-$pkgver/build"
+ make DESTDIR="$pkgdir" install
}