summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2019-08-03 18:51:42 -0500
committerAlejandro Valdes2019-08-03 18:51:42 -0500
commitbc41d15d31c33d8bd102ba20f051c534052218df (patch)
tree4fb904dae66e9e949dae921681c1caf0ba6f84ff
parent2327319ce96583874374e3aa0aece344dcc71c77 (diff)
downloadaur-bc41d15d31c33d8bd102ba20f051c534052218df.tar.gz
Bumping to 0.5.1
Added some optional dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD9
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe316f6d4590..6eedae99a989 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plasma5-applets-window-appmenu
pkgdesc = Plasma 5 applet in order to show the window appmenu
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 1
url = https://github.com/psifidotos/applet-window-appmenu
arch = x86_64
@@ -8,8 +8,10 @@ pkgbase = plasma5-applets-window-appmenu
makedepends = extra-cmake-modules
depends = plasma-workspace
depends = libxcb
- source = plasma5-applets-window-appmenu-0.5.0.tar.gz::https://github.com/psifidotos/applet-window-appmenu/archive/v0.5.0.tar.gz
- sha256sums = 4af9f4e7ba32edf4d405a9890e42fe7039281cc4a7bc124d05cb4ab47ef4bcee
+ optdepends = libdbusmenu-gtk3: gtk3 appmenu support
+ optdepends = libdbusmenu-gtk2: gtk2 appmenu support
+ source = plasma5-applets-window-appmenu-0.5.1.tar.gz::https://github.com/psifidotos/applet-window-appmenu/archive/v0.5.1.tar.gz
+ sha256sums = 890f55c36f64d7106276978e2133c4cd153a6345d11ae353522729d015be7f6a
pkgname = plasma5-applets-window-appmenu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad13f48e845d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index 74577e5e37d0..2e1f9a594c74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alejandro Valdes <alejandrovaldes@live.com>
pkgname=plasma5-applets-window-appmenu
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=1
pkgdesc="Plasma 5 applet in order to show the window appmenu"
arch=(x86_64)
@@ -9,8 +9,12 @@ url="https://github.com/psifidotos/applet-window-appmenu"
license=(GPL)
depends=(plasma-workspace libxcb)
makedepends=(extra-cmake-modules)
+optdepends=(
+ 'libdbusmenu-gtk3: gtk3 appmenu support'
+ 'libdbusmenu-gtk2: gtk2 appmenu support'
+)
source=($pkgname-$pkgver.tar.gz::"https://github.com/psifidotos/applet-window-appmenu/archive/v$pkgver.tar.gz")
-sha256sums=('4af9f4e7ba32edf4d405a9890e42fe7039281cc4a7bc124d05cb4ab47ef4bcee')
+sha256sums=('890f55c36f64d7106276978e2133c4cd153a6345d11ae353522729d015be7f6a')
prepare() {
mkdir -p build
@@ -26,4 +30,3 @@ package() {
cd build
make DESTDIR="$pkgdir" install
}
-