summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmal Karunarathna2018-11-22 02:46:40 +0530
committerAmal Karunarathna2018-11-22 02:46:40 +0530
commit9f6c1e805d524694d1fb4c68e265aac82e7a194d (patch)
tree877dc32f276144bf137572c7518f7050d449ee78
downloadaur-9f6c1e805d524694d1fb4c68e265aac82e7a194d.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c455574f529
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plasma5-applets-window-appmenu-git
+ pkgdesc = Plasma 5 applet in order to show the window appmenu
+ pkgver = r32.ff6ec9f
+ pkgrel = 1
+ url = https://github.com/psifidotos/applet-window-appmenu
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = plasma-workspace
+ conflicts = plasma5-applets-window-appmenu
+ source = git+https://github.com/psifidotos/applet-window-appmenu.git
+ sha256sums = SKIP
+
+pkgname = plasma5-applets-window-appmenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b27990caed00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+
+_gitname=applet-window-appmenu
+pkgname=plasma5-applets-window-appmenu-git
+pkgver=r32.ff6ec9f
+pkgrel=1
+pkgdesc="Plasma 5 applet in order to show the window appmenu"
+arch=(x86_64)
+url="https://github.com/psifidotos/${_gitname}"
+license=(GPL)
+depends=(plasma-workspace)
+makedepends=(git extra-cmake-modules)
+conflicts=(plasma5-applets-window-appmenu)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../applet-window-appmenu \
+ -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+} \ No newline at end of file