summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmal Karunarathna2018-11-22 20:10:39 +0530
committerAmal Karunarathna2018-11-22 20:10:39 +0530
commita2721eb15b4a48f009810a0c5c7ede9a6d564e1e (patch)
treee79605f83c3c34256bb955b28c378b2f63811851
downloadaur-a2721eb15b4a48f009810a0c5c7ede9a6d564e1e.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1a59d9482dd4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plasma5-applets-window-buttons-git
+ pkgdesc = Plasma 5 applet in order to show window buttons in your panels
+ pkgver = r71.07f4a22
+ pkgrel = 1
+ url = https://github.com/psifidotos/applet-window-buttons
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = extra-cmake-modules
+ depends = plasma-workspace
+ conflicts = plasma5-applets-window-buttons
+ source = git+https://github.com/psifidotos/applet-window-buttons.git
+ sha256sums = SKIP
+
+pkgname = plasma5-applets-window-buttons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6913d5e236b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+
+_gitname=applet-window-buttons
+pkgname=plasma5-applets-window-buttons-git
+pkgver=r71.07f4a22
+pkgrel=1
+pkgdesc="Plasma 5 applet in order to show window buttons in your panels"
+arch=(x86_64)
+url="https://github.com/psifidotos/${_gitname}"
+license=(GPL)
+depends=(plasma-workspace)
+makedepends=(git extra-cmake-modules)
+conflicts=(plasma5-applets-window-buttons)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../applet-window-buttons \
+ -DCMAKE_INSTALL_PREFIX=/usr
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}