summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2018-11-12 16:04:44 -0500
committerAlejandro Valdes2018-11-12 16:04:44 -0500
commit459ca155d86df1b2df940f074f48ef7dd62b9f70 (patch)
tree6fdab72528229bcefe24bf91da947b38957beded
downloadaur-459ca155d86df1b2df940f074f48ef7dd62b9f70.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2370efbcae80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plasma5-applets-window-title
+ pkgdesc = Plasma 5 applet that shows the application title and icon for active window
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/psifidotos/applet-window-title
+ arch = x86_64
+ license = GPL
+ depends = plasma-workspace
+ source = https://github.com/psifidotos/applet-window-title/archive/v0.1.tar.gz
+ sha512sums = f478eeac90801c35d4a8b0717603d8e60943d1841f567835a2cbc83c7246af30681cec90b4538671ee86fc986af093db3c4297f6fa663020a63cd4d9ba1857f8
+
+pkgname = plasma5-applets-window-title
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a61652f2808
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Alejandro Valdes <alejandrovaldes@live.com>
+
+pkgname=plasma5-applets-window-title
+pkgver=0.1
+pkgrel=1
+pkgdesc="Plasma 5 applet that shows the application title and icon for active window"
+arch=(x86_64)
+url="https://github.com/psifidotos/applet-window-title"
+license=(GPL)
+depends=(plasma-workspace)
+source=("https://github.com/psifidotos/applet-window-title/archive/v$pkgver.tar.gz")
+sha512sums=('f478eeac90801c35d4a8b0717603d8e60943d1841f567835a2cbc83c7246af30681cec90b4538671ee86fc986af093db3c4297f6fa663020a63cd4d9ba1857f8')
+
+package() {
+ _pkgdir="$pkgdir/usr/share/plasma/plasmoids/org.kde.windowtitle"
+ mkdir -p "$_pkgdir"
+ cp -r applet-window-title-$pkgver/* "$_pkgdir"
+ rm "$_pkgdir/README.md"
+}