summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmal Karunarathna2018-11-22 03:04:55 +0530
committerAmal Karunarathna2018-11-22 03:04:55 +0530
commitc74d445d10549012b1923de328ce69fa2819e61b (patch)
tree733a68d8707d6658ec6e4ba2f33b5f1a0ad45bcc
downloadaur-c74d445d10549012b1923de328ce69fa2819e61b.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..801afbc3f73f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = plasma5-applets-window-title-git
+ pkgdesc = Plasma 5 applet that shows the application title and icon for active window
+ pkgver = r31.c8b216a
+ pkgrel = 1
+ url = https://github.com/psifidotos/applet-window-title
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = plasma-workspace
+ conflicts = plasma5-applets-window-title
+ source = git+https://github.com/psifidotos/applet-window-title.git
+ sha256sums = SKIP
+
+pkgname = plasma5-applets-window-title-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39e6f678a496
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Amal Karunarathna <nasashinega@gmail.com>
+
+_gitname=applet-window-title
+pkgname=plasma5-applets-window-title-git
+pkgver=r31.c8b216a
+pkgrel=1
+pkgdesc="Plasma 5 applet that shows the application title and icon for active window"
+arch=(x86_64)
+url="https://github.com/psifidotos/${_gitname}"
+license=(GPL)
+depends=(plasma-workspace)
+makedepends=(git)
+conflicts=(plasma5-applets-window-title)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver(){
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ _pkgdir="$pkgdir/usr/share/plasma/plasmoids/org.kde.windowtitle"
+ mkdir -p "$_pkgdir"
+ cp -r applet-window-title/* "$_pkgdir"
+ rm "$_pkgdir/README.md"
+} \ No newline at end of file