summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkikadf2016-04-05 17:21:02 +0200
committerkikadf2016-04-05 17:21:02 +0200
commit43326f7ddd3a34cad776d09a8a7fa4e1240bee24 (patch)
tree33c86d24f804dca967e652bef701e435aa359324
downloadaur-43326f7ddd3a34cad776d09a8a7fa4e1240bee24.tar.gz
New package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa58b2f833ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plasma5-applets-yahoo-weather-widget
+ pkgdesc = A simple weather widget that makes use of beloved Yahoo! Weather data
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = http://kde-apps.org/content/show.php/Yahoo%21+Weather+Widget?content=164194
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ depends = plasma-workspace
+ depends = qt5-declarative
+ source = https://github.com/librehat/com.librehat.yahooweather/archive/v5.1.0.tar.gz
+ md5sums = 17bd3327fa711fc0ec2addd58f2c95d5
+
+pkgname = plasma5-applets-yahoo-weather-widget
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d11122c0e824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: kikadf <kikadf.01@gmail.com>
+
+pkgname=plasma5-applets-yahoo-weather-widget
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="A simple weather widget that makes use of beloved Yahoo! Weather data"
+arch=(i686 x86_64)
+url="http://kde-apps.org/content/show.php/Yahoo%21+Weather+Widget?content=164194"
+_watch="lynx -dump -listonly "https://github.com/librehat/com.librehat.yahooweather/tags" | sed -n 's|.*archive/v\([5-9].*\).tar.gz|\1|p' | head -1"
+license=(GPL)
+depends=(plasma-workspace qt5-declarative)
+makedepends=(extra-cmake-modules)
+source=("https://github.com/librehat/com.librehat.yahooweather/archive/v$pkgver.tar.gz")
+md5sums=('17bd3327fa711fc0ec2addd58f2c95d5')
+
+prepare() {
+ cd com.librehat.yahooweather-$pkgver
+ mkdir -p build
+}
+
+build() {
+ cd com.librehat.yahooweather-$pkgver/build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+}
+
+package() {
+ cd com.librehat.yahooweather-$pkgver/build
+ make DESTDIR="$pkgdir" install
+}