summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Aaron Goldberg2021-04-18 12:32:06 -0400
committerBen Aaron Goldberg2021-04-18 12:32:06 -0400
commit1a6fdb7f6b3e37f3365f1b9b4609c4681d518b4a (patch)
treea5f21071684957cff9c516f76574687120fe9abe
downloadaur-1a6fdb7f6b3e37f3365f1b9b4609c4681d518b4a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bbfd1e80b032
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = plasma5-runners-poki-launcher-bin
+ pkgdesc = An application launcher that shows recently used apps first
+ pkgver = 0.7.0
+ pkgrel = 1
+ url = https://sr.ht/~zethra/poki-launcher/
+ arch = x86_64
+ license = GPL3
+ makedepends = rust
+ makedepends = cargo
+ depends = krunner
+ source = poki-launcher-src-0.7.0.tar.gz::https://git.sr.ht/~zethra/poki-launcher/archive/0.7.0.tar.gz
+ source = poki-krunner-bin-0.7.0.gz::https://git.sr.ht/~zethra/poki-launcher/refs/download/0.7.0/poki-launcher-0.7.0-x86_64-unknown-linux-gnu.gz
+ sha256sums = e0578de1a3916efdd962f24bc8c8fa3a26916e97e56627ffeeb84493f8b206e6
+ sha256sums = 8262f6e67aaac98e549afc36bacfe64aa87453933a9971974ff7167d2fb03c9e
+
+pkgname = plasma5-runners-poki-launcher-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a8d60ed9e084
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/*.tar*
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f8713bba99f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ben Aaron Goldberg <ben@benaaron.dev>
+
+pkgname=plasma5-runners-poki-launcher-bin
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="An application launcher that shows recently used apps first"
+arch=('x86_64')
+url="https://sr.ht/~zethra/poki-launcher/"
+license=('GPL3')
+source=("poki-launcher-src-$pkgver.tar.gz::https://git.sr.ht/~zethra/poki-launcher/archive/$pkgver.tar.gz"
+"poki-krunner-bin-$pkgver.gz::https://git.sr.ht/~zethra/poki-launcher/refs/download/$pkgver/poki-launcher-$pkgver-x86_64-unknown-linux-gnu.gz")
+depends=('krunner')
+makedepends=('rust' 'cargo')
+sha256sums=("e0578de1a3916efdd962f24bc8c8fa3a26916e97e56627ffeeb84493f8b206e6"
+"8262f6e67aaac98e549afc36bacfe64aa87453933a9971974ff7167d2fb03c9e")
+
+_realname=plasma5-runners-poki-launcher
+
+package() {
+ install -Dm755 "poki-krunner-bin-$pkgver" "$pkgdir/usr/bin/poki-krunner"
+ cd "poki-launcher-$pkgver"
+ install -Dm644 "poki-krunner/dev.benaaron.poki-krunner.service" \
+ "$pkgdir/usr/share/dbus-1/services/dev.benaaron.poki-krunner.service"
+ install -Dm644 "poki-krunner/plasma-runner-poki-launcher.desktop" \
+ "$pkgdir/usr/share/krunner/dbusplugins/plasma-runner-poki-launcher.desktop"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$_realname/README.md"
+ install -Dm644 "poki-launcher.hjson" "$pkgdir/usr/share/doc/$_realname/examples/poki-launcher.hjson"
+}