summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss2017-03-05 14:47:40 +0100
committerLuca Weiss2017-03-05 14:47:40 +0100
commitb14fbdce0224998171b4e98723ac2d299a215543 (patch)
treedcc50a901ee15c87584b3916539ed18c47fefc59
downloadaur-b14fbdce0224998171b4e98723ac2d299a215543.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e4e8cc4276e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Mar 5 13:47:34 UTC 2017
+pkgbase = plasma5-wallpapers-video-git
+ pkgdesc = Allows the use of video wallpaper and lock screen.
+ pkgver = r4.f8ec6f9
+ pkgrel = 1
+ url = https://github.com/halverneus/org.kde.video
+ arch = any
+ license = unknown
+ makedepends = git
+ optdepends = gst-plugins-bad: more codecs
+ optdepends = gst-plugins-ugly: more codecs
+ provides = plasma5-wallpapers-video
+ conflicts = plasma5-wallpapers-video
+ source = git+https://github.com/halverneus/org.kde.video
+ sha512sums = SKIP
+
+pkgname = plasma5-wallpapers-video-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb510038c165
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luca Weiss <luca (at) z3ntu (dot) xyz>
+
+# Tip: If your video doesn't play, take a look at "journalctl -b"
+
+_pkgname=org.kde.video
+pkgname=plasma5-wallpapers-video-git
+pkgver=r4.f8ec6f9
+pkgrel=1
+pkgdesc="Allows the use of video wallpaper and lock screen."
+arch=("any")
+url="https://github.com/halverneus/org.kde.video"
+license=('unknown')
+optdepends=('gst-plugins-bad: more codecs' 'gst-plugins-ugly: more codecs')
+makedepends=('git')
+provides=("plasma5-wallpapers-video")
+conflicts=("plasma5-wallpapers-video")
+source=('git+https://github.com/halverneus/org.kde.video')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/plasma/wallpapers/$_pkgname"
+ cp -r "$srcdir/$_pkgname/"* "$pkgdir/usr/share/plasma/wallpapers/$_pkgname"
+}