summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTechwizz2022-03-18 19:52:18 -0600
committerTechwizz2022-03-18 19:52:18 -0600
commit0fdee06e4a3fc4bd5b11fa3d74f1da5cc1a239c8 (patch)
treeea253c1d2811aca83580be7d55934ebc0d4e6084
downloadaur-0fdee06e4a3fc4bd5b11fa3d74f1da5cc1a239c8.tar.gz
Inital commit
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD19
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bedec2c56cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,46 @@
+pkgbase = plasticity-bin
+ pkgdesc = Plasticity is a 3d modelling software for concept artists. Modeling in Plasticity is quick and efficient due to the unique gizmos, shortcuts, and thoughtful workflow.
+ pkgver = 0.5.32
+ pkgrel = 1
+ url = https://github.com/nkallen/plasticity
+ arch = x86_64
+ license = LGPL-3.0
+ depends = alsa-lib
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = atk
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = expat
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = gvfs
+ depends = hicolor-icon-theme
+ depends = kde-cli-tools
+ depends = libcups
+ depends = libdrm
+ depends = libnotify
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxkbcommon
+ depends = libxrandr
+ depends = libxtst
+ depends = mesa
+ depends = nspr
+ depends = nss
+ depends = pango
+ depends = trash-cli
+ depends = xdg-utils
+ optdepends = discord: For communication with the devs
+ optdepends = apparmor: Extra protection
+ optdepends = pulseaudio: For sound
+ source = plasticity_0.5.32_amd64.deb::https://github.com/nkallen/plasticity/releases/download/v0.5.32/plasticity_0.5.32_amd64.deb
+ sha512sums = d300b9e41976c9507973833ccb3594e107322179e1a3a391e9a5ab8e0a5b9e59ea7ce153c9830f3b754cc3519ed3531739b6529053253f02f219cdc7911e0e6f
+
+pkgname = plasticity-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d0f07c92afa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Paul Black <paulrblack.prb@gmail.com>
+
+pkgname="plasticity-bin"
+pkgver="0.5.32"
+pkgrel="1"
+pkgdesc="Plasticity is a 3d modelling software for concept artists. Modeling in Plasticity is quick and efficient due to the unique gizmos, shortcuts, and thoughtful workflow."
+arch=("x86_64")
+license=("LGPL-3.0")
+url='https://github.com/nkallen/plasticity'
+depends=(alsa-lib at-spi2-atk at-spi2-core atk cairo dbus desktop-file-utils expat gdk-pixbuf2 glib2 gtk3 gvfs hicolor-icon-theme kde-cli-tools libcups libdrm libnotify libx11 libxcb libxcomposite libxdamage libxext libxfixes libxkbcommon libxrandr libxtst mesa nspr nss pango trash-cli xdg-utils)
+optdepends=('discord: For communication with the devs' 'apparmor: Extra protection' 'pulseaudio: For sound')
+source=("plasticity_${pkgver}_amd64.deb::https://github.com/nkallen/plasticity/releases/download/v${pkgver}/plasticity_${pkgver}_amd64.deb")
+sha512sums=("d300b9e41976c9507973833ccb3594e107322179e1a3a391e9a5ab8e0a5b9e59ea7ce153c9830f3b754cc3519ed3531739b6529053253f02f219cdc7911e0e6f")
+
+package() {
+ tar -xf data.tar.xz
+
+ cp -r "$srcdir/usr" -t "$pkgdir"
+}