summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Downey2020-05-03 13:06:09 -0500
committerJohn Downey2020-05-03 13:10:47 -0500
commit9b9095c1e1aa8f82b312589cedf53fbe76c300f0 (patch)
tree28bcd88ec775dd66d16556fac125348c850236c6
downloadaur-9b9095c1e1aa8f82b312589cedf53fbe76c300f0.tar.gz
Add initial package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e199a0a1270
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plater
+ pkgdesc = 3D-printer parts placer and plate generator
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/Rhoban/Plater
+ arch = x86_64
+ license = custom:CC BY-NC
+ makedepends = cmake
+ depends = libffi
+ source = https://github.com/Rhoban/Plater/archive/v1.0.0.tar.gz
+ sha256sums = 4baafed6fe779dc0711dbcb0385dbe96f2212f343f419fe98e4e5f394ad3bfc9
+
+pkgname = plater
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b9f86618773
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: John Downey <jdowney@gmail.com>
+pkgname=plater
+pkgver=1.0.0
+pkgrel=1
+epoch=
+pkgdesc="3D-printer parts placer and plate generator"
+arch=("x86_64")
+url="https://github.com/Rhoban/Plater"
+license=("custom:CC BY-NC")
+groups=()
+depends=("libffi")
+makedepends=("cmake")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/Rhoban/Plater/archive/v$pkgver.tar.gz")
+noextract=()
+sha256sums=("4baafed6fe779dc0711dbcb0385dbe96f2212f343f419fe98e4e5f394ad3bfc9")
+validpgpkeys=()
+
+build() {
+ cd "Plater-$pkgver/plater"
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "Plater-$pkgver/plater/build"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 ../../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}