summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsum012018-05-23 10:57:49 -0400
committersum012018-05-23 10:57:49 -0400
commit7d0f30342d7c1788274bd110e04d416c04a26a3a (patch)
tree48bed72c57b6c591bd3f505a6bd9cfd9ea3e5660
parentc574110b49508588adee06cf162f40dd1f0a33d2 (diff)
downloadaur-7d0f30342d7c1788274bd110e04d416c04a26a3a.tar.gz
Fix check step and remove dep
I incorrectly named the check function 'test'. coreutils are also not necessary to be added as dependencies.
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a6ef7f8ddff..ed11b1a14d02 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = platformfolders
pkgdesc = A C++ library to look for special directories like "My Documents" and "%APPDATA%" so that you do not need to write Linux, Windows and Mac OS X specific code
pkgver = 3.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sago007/PlatformFolders
arch = i686
arch = x86_64
license = MIT
makedepends = cmake>=3.0.0
makedepends = make
- makedepends = coreutils
- source = https://github.com/sago007/PlatformFolders/archive/3.1.tar.gz
+ source = platformfolders-3.1.tar.gz::https://github.com/sago007/PlatformFolders/archive/3.1.tar.gz
sha512sums = 62e73fe049759584b9fa245820ced54e01c110f100ddf2de58d5f8b287ae899515eb61dcb9dd8d9411b955c75caf64f019df4516723de61358568d5d8a07c507
pkgname = platformfolders
diff --git a/PKGBUILD b/PKGBUILD
index e80c461388af..04d62eb56fb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=platformfolders
_realpkgname=PlatformFolders
pkgver=3.1
-pkgrel=1
+pkgrel=2
pkgdesc='A C++ library to look for special directories like "My Documents" and "%APPDATA%" so that you do not need to write Linux, Windows and Mac OS X specific code'
arch=('i686' 'x86_64')
url="https://github.com/sago007/PlatformFolders"
license=('MIT')
-makedepends=('cmake>=3.0.0' 'make' 'coreutils')
-source=("https://github.com/sago007/PlatformFolders/archive/${pkgver}.tar.gz")
+makedepends=('cmake>=3.0.0' 'make')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/sago007/PlatformFolders/archive/${pkgver}.tar.gz")
sha512sums=('62e73fe049759584b9fa245820ced54e01c110f100ddf2de58d5f8b287ae899515eb61dcb9dd8d9411b955c75caf64f019df4516723de61358568d5d8a07c507')
build() {
mkdir -p "$srcdir/$_realpkgname-$pkgver/build"
@@ -17,7 +17,7 @@ build() {
cmake -DBUILD_TESTING=OFF -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib ..
make
}
-test() {
+check() {
cd "$srcdir/$_realpkgname-$pkgver/build"
cmake -DBUILD_TESTING=ON ..
make