summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2021-02-22 12:17:44 +0100
committerJake2021-02-22 12:17:44 +0100
commit39d288896da97c356863a1ff5c813afa16726569 (patch)
tree0af8f2cbabd07a440a6cdc15611221daac4174de
parentbd7f23c7eff6e096e3cbdbde379e14b07315886e (diff)
downloadaur-39d288896da97c356863a1ff5c813afa16726569.tar.gz
Add missing deps for 5.1.0
needed for the home command
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index accfd90e0d6b..9338129a5bf0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = platformio
pkgdesc = A cross-platform code builder and library manager
pkgver = 5.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/platformio/platformio-core/
arch = any
license = Apache
@@ -15,6 +15,11 @@ pkgbase = platformio
depends = python-tabulate
depends = python-pyelftools
depends = python-marshmallow
+ depends = python-aiofiles
+ depends = python-json-rpc
+ depends = python-starlette
+ depends = python-wsproto
+ depends = uvicorn
optdepends = python-click-completion: for shell completions
optdepends = python-shellingham: for shell completions
conflicts = platformio-git
@@ -22,4 +27,3 @@ pkgbase = platformio
sha256sums = 3579411f44f490282be3eba552a672bd8afe8d7198faefca25a3c5e0d19d34b7
pkgname = platformio
-
diff --git a/PKGBUILD b/PKGBUILD
index affae0400600..05d7992cf6ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=platformio
pkgver=5.1.0
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="https://github.com/platformio/platformio-core/"
@@ -23,7 +23,13 @@ depends=('python-setuptools'
'python-semantic-version'
'python-tabulate'
'python-pyelftools'
- 'python-marshmallow')
+ 'python-marshmallow'
+ # "pio home" requirements:
+ 'python-aiofiles'
+ 'python-json-rpc'
+ 'python-starlette'
+ 'python-wsproto'
+ 'uvicorn')
optdepends=('python-click-completion: for shell completions'
'python-shellingham: for shell completions')
conflicts=('platformio-git')