summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2019-07-13 20:30:47 +0200
committerJake2019-07-13 20:30:47 +0200
commit8eaedcb9e799ea2c436408344eacdf488f502d1a (patch)
treefb401610591bb702d9141d99de7cdaffac452d90
parent1a27eed2530706bd49afbf5e8e385f11d14266f8 (diff)
downloadaur-8eaedcb9e799ea2c436408344eacdf488f502d1a.tar.gz
Update to 4.0.0
switch to python(3)
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD25
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3c8b7e25513..fc549cdd4a50 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = platformio
pkgdesc = A cross-platform code builder and library manager
- pkgver = 3.6.7
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/platformio/platformio-core/
arch = any
license = Apache
- depends = python2
- depends = python2-arrow
- depends = python2-bottle
- depends = python2-click-5.1
- depends = python2-colorama
- depends = python2-lockfile
- depends = python2-pyserial>=3.4
- depends = python2-requests
- depends = python2-semantic-version
- depends = python2-setuptools
+ depends = python-bottle
+ depends = python-click
+ depends = python-colorama
+ depends = python-lockfile
+ depends = python-pyserial>=3.4
+ depends = python-requests
+ depends = python-semantic-version
+ depends = python-setuptools
conflicts = platformio-git
- source = https://github.com/platformio/platformio-core/archive/v3.6.7.tar.gz
- sha256sums = 0486cf72c02ade8ce26643c33784f8f801860c7c5149f5a511a6dedcee341869
+ source = https://github.com/platformio/platformio-core/archive/v4.0.0.tar.gz
+ sha256sums = 873a1484e41d506e9ef6f3135fac5b12a8b46db893e6a2fe904578d3c419cec7
pkgname = platformio
diff --git a/PKGBUILD b/PKGBUILD
index 3793f187b2f0..00fe8daf2a40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,28 +8,25 @@
#
pkgname=platformio
-pkgver=3.6.7
+pkgver=4.0.0
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="https://github.com/platformio/platformio-core/"
license=('Apache')
-depends=('python2'
- 'python2-arrow'
- 'python2-bottle'
- 'python2-click-5.1' # https://github.com/platformio/platformio/issues/349
- 'python2-colorama'
- 'python2-lockfile'
- 'python2-pyserial>=3.4'
-# https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc
- 'python2-requests'
- 'python2-semantic-version'
- 'python2-setuptools')
+depends=('python-bottle'
+ 'python-click'
+ 'python-colorama'
+ 'python-lockfile'
+ 'python-pyserial>=3.4' #https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc
+ 'python-requests'
+ 'python-semantic-version'
+ 'python-setuptools')
conflicts=('platformio-git')
source=("https://github.com/platformio/platformio-core/archive/v${pkgver}.tar.gz")
-sha256sums=('0486cf72c02ade8ce26643c33784f8f801860c7c5149f5a511a6dedcee341869')
+sha256sums=('873a1484e41d506e9ef6f3135fac5b12a8b46db893e6a2fe904578d3c419cec7')
package() {
cd "$srcdir/platformio-core-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1
}