summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhelm Savin2016-11-11 19:43:26 +0800
committerGuilhelm Savin2016-11-11 19:43:26 +0800
commit9775ab25fd596f58e9fcbb5afa82b97faf6da9a8 (patch)
treeaef567be6d03072fd8391994c4253d5b583e658f
parent3b85ec1018730279efa1c43ff4b2e3fdf7c10358 (diff)
downloadaur-9775ab25fd596f58e9fcbb5afa82b97faf6da9a8.tar.gz
Update to 3.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
-rw-r--r--setup.patch11
3 files changed, 16 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f338fd23ea5..7ddc74a43c4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = platformio
pkgdesc = A cross-platform code builder and library manager
- pkgver = 2.11.2
+ pkgver = 3.1.0
pkgrel = 1
url = https://github.com/platformio/platformio/
arch = any
license = Apache
depends = python2
- depends = python2-setuptools
- depends = python2-click
depends = python2-bottle
- depends = python2-lockfile
- depends = python2-requests
+ depends = python2-click-5.1
depends = python2-colorama
+ depends = python2-lockfile
depends = python2-pyserial
- optdepends = energia: For MSP430 based projects
- optdepends = arduino: For Arduino based projects
+ depends = python2-requests
+ depends = python2-semantic-version
+ depends = python2-setuptools
conflicts = platformio-git
- source = https://github.com/platformio/platformio/archive/v2.11.2.tar.gz
- source = setup.patch
- sha256sums = 72b373b4e653b76df17d41e4962ae4d6e1f7f705b0c9931b0ec360cc60ee1865
- sha256sums = 536217552b06ef562469268a8f0115a31bf052308f891a228adf94e314ce3730
+ source = https://github.com/platformio/platformio/archive/v3.1.0.tar.gz
+ sha256sums = 80b22f4322904648ea4b355935ea9315cfd765c3286022b54b75227e1be03d83
pkgname = platformio
diff --git a/PKGBUILD b/PKGBUILD
index 72af6b47e74b..a91819072b8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,32 +7,24 @@
#
pkgname=platformio
-pkgver=2.11.2
+pkgver=3.1.0
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="https://github.com/platformio/platformio/"
license=('Apache')
depends=('python2'
- 'python2-setuptools'
- 'python2-click'
'python2-bottle'
+ 'python2-click-5.1' # https://github.com/platformio/platformio/issues/349
+ 'python2-colorama'
'python2-lockfile'
+ 'python2-pyserial'
'python2-requests'
- 'python2-colorama'
- 'python2-pyserial')
-optdepends=('energia: For MSP430 based projects'
- 'arduino: For Arduino based projects')
+ 'python2-semantic-version'
+ 'python2-setuptools')
conflicts=('platformio-git')
-source=("https://github.com/platformio/platformio/archive/v${pkgver}.tar.gz"
- "setup.patch")
-sha256sums=('72b373b4e653b76df17d41e4962ae4d6e1f7f705b0c9931b0ec360cc60ee1865'
- '536217552b06ef562469268a8f0115a31bf052308f891a228adf94e314ce3730')
-
-prepare() {
- cd "platformio-$pkgver"
- patch -Np0 -i ${srcdir}/setup.patch
-}
+source=("https://github.com/platformio/platformio/archive/v${pkgver}.tar.gz")
+sha256sums=('80b22f4322904648ea4b355935ea9315cfd765c3286022b54b75227e1be03d83')
package() {
cd "$srcdir/platformio-$pkgver"
diff --git a/setup.patch b/setup.patch
deleted file mode 100644
index 682d61342f8f..000000000000
--- a/setup.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py 2016-02-17 21:53:08.000000000 +0100
-+++ setup.py 2016-02-19 11:10:03.463588205 +0100
-@@ -21,7 +21,7 @@
-
- install_requires = [
- "bottle<0.13",
-- "click>=3.2,<6",
-+ "click>=3.2",
- "lockfile>=0.9.1,<0.13",
- "requests>=2.4.0,<3",
- "colorama",