summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhelm Savin2016-02-11 16:13:37 +0100
committerGuilhelm Savin2016-02-11 16:13:37 +0100
commitefb2f7686d8deb3d154a3b9615e55281f07a8f62 (patch)
tree21b8dc6f484baf2129f1c68f7843a44985481e82
downloadaur-efb2f7686d8deb3d154a3b9615e55281f07a8f62.tar.gz
Initial import. Up to release 2.8.3.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD37
-rw-r--r--setup.patch4
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..702e39378dba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by makepkg 5.0.0
+# Thu Feb 11 15:09:40 UTC 2016
+pkgbase = platformio
+ pkgdesc = A cross-platform code builder and library manager
+ pkgver = 2.8.3
+ pkgrel = 1
+ url = https://github.com/platformio/platformio/
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-click
+ depends = python2-bottle
+ depends = python2-lockfile
+ depends = python2-requests
+ depends = python2-colorama
+ depends = python2-pyserial
+ optdepends = energia: For MSP430 based projects
+ optdepends = arduino: For Arduino based projects
+ conflicts = platformio-git
+ source = https://github.com/platformio/platformio/archive/v2.8.3.tar.gz
+ sha256sums = b37cccd70281b9c1d597fc3c05c7a3524ccf8a83668a1172e4790d3b025961db
+
+pkgname = platformio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5ba2dae4c89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+#
+# Maintainer: Guilhelm Savin <aur@gsav.in>
+# Upstream URL: https://github.com/platformio/platformio
+#
+# For improvements/fixes to this package, please send a pull request:
+# https://github.com/gsavin/arch
+#
+
+pkgname=platformio
+pkgver=2.8.3
+pkgrel=1
+pkgdesc="A cross-platform code builder and library manager"
+arch=('any')
+url="https://github.com/platformio/platformio/"
+license=('GPL')
+depends=('python2'
+ 'python2-click'
+ 'python2-bottle'
+ 'python2-lockfile'
+ 'python2-requests'
+ 'python2-colorama'
+ 'python2-pyserial')
+optdepends=('energia: For MSP430 based projects'
+ 'arduino: For Arduino based projects')
+conflicts=('platformio-git')
+source=("https://github.com/platformio/platformio/archive/v${pkgver}.tar.gz")
+sha256sums=('b37cccd70281b9c1d597fc3c05c7a3524ccf8a83668a1172e4790d3b025961db')
+
+prepare() {
+ cd "platformio-$pkgver"
+ patch setup.py ${startdir}/setup.patch
+}
+
+package() {
+ cd "$srcdir/platformio-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..684afe09037d
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,4 @@
+24c24
+< "click>=3.2,<6",
+---
+> "click>=3.2",