summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJake2020-02-13 20:21:38 +0100
committerJake2020-02-13 20:21:38 +0100
commitf335abb5111f6b62d9c7ed46507be96e4d966f68 (patch)
tree289a8f90410a1d848a31d53a317d4a490c02ad10
parent7473e9f24c41a64fbeb55f8736dda73aa38e74ef (diff)
downloadaur-f335abb5111f6b62d9c7ed46507be96e4d966f68.tar.gz
Update to 4.2.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aa468edaac1..b2138fb6a82f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = platformio
pkgdesc = A cross-platform code builder and library manager
- pkgver = 4.0.2
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/platformio/platformio-core/
arch = any
license = Apache
+ depends = python-setuptools
depends = python-bottle
depends = python-click
depends = python-colorama
- depends = python-lockfile
depends = python-pyserial>=3.4
depends = python-requests
depends = python-semantic-version
- depends = python-setuptools
depends = python-tabulate
+ depends = python-pyelftools
+ depends = python-marshmallow
conflicts = platformio-git
- source = https://github.com/platformio/platformio-core/archive/v4.0.2.tar.gz
- sha256sums = 1fb3dcdf31b71896eeaa04cd113135274ef630219ab4f692a6bde7b3ca98cc70
+ source = https://github.com/platformio/platformio-core/archive/v4.2.0.tar.gz
+ sha256sums = ae60d49ab6ac4c07d46196c30119339ae16f0e3c792c51376fdd12faa6204b48
pkgname = platformio
diff --git a/PKGBUILD b/PKGBUILD
index 6cb5ffdd8a08..5c7e48b4af92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,24 +8,25 @@
#
pkgname=platformio
-pkgver=4.0.2
+pkgver=4.2.0
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="https://github.com/platformio/platformio-core/"
license=('Apache')
-depends=('python-bottle'
+depends=('python-setuptools'
+ 'python-bottle'
'python-click'
'python-colorama'
- 'python-lockfile'
'python-pyserial>=3.4' #https://github.com/platformio/platformio-core/commit/a37eb9868f3b20e982d0c3cd1a742fcb8ab60efc
'python-requests'
'python-semantic-version'
- 'python-setuptools'
- 'python-tabulate')
+ 'python-tabulate'
+ 'python-pyelftools'
+ 'python-marshmallow')
conflicts=('platformio-git')
source=("https://github.com/platformio/platformio-core/archive/v${pkgver}.tar.gz")
-sha256sums=('1fb3dcdf31b71896eeaa04cd113135274ef630219ab4f692a6bde7b3ca98cc70')
+sha256sums=('ae60d49ab6ac4c07d46196c30119339ae16f0e3c792c51376fdd12faa6204b48')
package() {
cd "$srcdir/platformio-core-$pkgver"