summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Garnica2019-02-06 10:08:21 +0100
committerSergio Garnica2019-02-06 10:08:21 +0100
commit403eda4aa7deacb00662e7075fa9001d9167a54f (patch)
tree8007fbe2d07d6a33cbf7341fffa65e9cfef8959e
parent122deed45548522a19ce4f2a681f4ae23f50d9e8 (diff)
downloadaur-403eda4aa7deacb00662e7075fa9001d9167a54f.tar.gz
Compile with python 3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD31
2 files changed, 29 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e87cc5a18d7..2e3ca635d112 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
-# Generated by mksrcinfo v8
-# Sat Sep 16 10:11:36 UTC 2017
pkgbase = platformio-git
pkgdesc = A cross-platform code builder and library manager
- pkgver = v3.3.0.r296.gaa1c7609
+ pkgver = v3.6.4.r31.g31d4706a
pkgrel = 1
url = http://platformio.org/
arch = any
license = GPL
- depends = python2
- depends = python2-arrow
- depends = python2-bottle
- depends = python2-click-5.1
- depends = python2-colorama
- depends = python2-lockfile
- depends = python2-pyserial
- depends = python2-requests
- depends = python2-semantic-version
+ depends = python-setuptools
+ depends = python-arrow
+ depends = python-bottle
+ depends = python-click-5.1
+ depends = python-colorama
+ depends = python-lockfile
+ depends = python-pyserial
+ depends = python-requests
+ depends = python-semantic-version
optdepends = energia: For MSP430 based projects
optdepends = arduino: For Arduino based projects
source = git+https://github.com/platformio/platformio-core.git
diff --git a/PKGBUILD b/PKGBUILD
index d44f1cc3f7f8..da16ccd6caad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Will Price <will.price94+aur@gmail.com>
+# Maintainer: S garnica < swhaat at github >
+# Contributor: Will Price <will.price94+aur@gmail.com>
# Contributor: Brice Waegeneire <bricewge at gmail dot com>
pkgname=platformio-git
_pkgname=platformio-core
-pkgver=v3.3.0.r296.gaa1c7609
+pkgver=v3.6.4.r31.g31d4706a
pkgrel=1
pkgdesc="A cross-platform code builder and library manager"
arch=('any')
url="http://platformio.org/"
license=('GPL')
-depends=('python2'
- 'python2-arrow'
- 'python2-bottle'
- 'python2-click-5.1'
- 'python2-colorama'
- 'python2-lockfile'
- 'python2-pyserial'
- 'python2-requests'
- 'python2-semantic-version')
+depends=('python-setuptools'
+ 'python-arrow'
+ 'python-bottle'
+ 'python-click-5.1'
+ 'python-colorama'
+ 'python-lockfile'
+ 'python-pyserial'
+ 'python-requests'
+ 'python-semantic-version')
optdepends=('energia: For MSP430 based projects'
'arduino: For Arduino based projects')
source=('git+https://github.com/platformio/platformio-core.git')
@@ -28,7 +29,13 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+build()
+{
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
package() {
cd "$srcdir/${_pkgname}"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}