summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Manganiello2021-02-22 22:06:57 +0100
committerFabio Manganiello2021-02-22 22:06:57 +0100
commit50fea14e16c827cb63f8fc39c7abcf6e8a6398d4 (patch)
treeaa7cdc1576e36a37f6c5667c5d8f8b9df9b41a9f
parentc5319a23bda629fa9ffb58b99bbefcc493bbe1f8 (diff)
downloadaur-50fea14e16c827cb63f8fc39c7abcf6e8a6398d4.tar.gz
s/github/gitlab/g and added new dependencies
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 379f7e14abbd..dc65b746282a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = platypush
pkgdesc = Universal multi-platform command executor and automation manager
pkgver = 0.13.4
pkgrel = 1
- url = https://github.com/BlackLight/platypush
+ url = https://git.platypush.tech/platypush/platypush
arch = any
license = MIT
depends = python
@@ -15,9 +15,12 @@ pkgbase = platypush
depends = python-websocket-client
depends = python-wheel
depends = python-flask
+ depends = python-pip
depends = python-dateutil
depends = python-frozendict
depends = python-bcrypt
+ depends = python-zeroconf
+ depends = python-pyjwt
optdepends = python-paho-mqtt: MQTT integrations support
optdepends = python-pybluez: Bluetooth support
optdepends = python-gattlib: Low-energy Bluetooth devices support
@@ -26,7 +29,7 @@ pkgbase = platypush
optdepends = python-pyserial: Arduino/serial device support
conflicts = platypush-git
options = !strip
- source = platypush-0.13.4.tar.gz::https://github.com/BlackLight/platypush/archive/v0.13.4.tar.gz
+ source = platypush-0.13.4.tar.gz::https://git.platypush.tech/platypush/platypush/-/archive/v0.13.4/platypush-v0.13.4.tar.gz
sha512sums = 182a7087bbbb01dfc3b4c76439f8cf215b58248b935b2a5924a85753ab4adf5224049935fb7980a03d0a14627ae11301cc43cb06229127f674c1ae828cb3f840
pkgname = platypush
diff --git a/PKGBUILD b/PKGBUILD
index ad04cb61433c..43a0f4260d0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,8 @@ pkgrel=1
pkgdesc="Universal multi-platform command executor and automation manager"
arch=('any')
license=('MIT')
-url="https://github.com/BlackLight/platypush"
-depends=('python' 'python-yaml' 'redis' 'python-redis' 'python-requests' 'python-sqlalchemy' 'python-websockets' 'python-websocket-client' 'python-wheel' 'python-flask'
- 'python-dateutil' 'python-frozendict' 'python-bcrypt')
+url="https://git.platypush.tech/platypush/platypush"
+depends=('python' 'python-yaml' 'redis' 'python-redis' 'python-requests' 'python-sqlalchemy' 'python-websockets' 'python-websocket-client' 'python-wheel' 'python-flask' 'python-pip' 'python-dateutil' 'python-frozendict' 'python-bcrypt' 'python-zeroconf' 'python-pyjwt')
optdepends=('python-paho-mqtt: MQTT integrations support'
'python-pybluez: Bluetooth support'
'python-gattlib: Low-energy Bluetooth devices support'
@@ -17,7 +16,7 @@ optdepends=('python-paho-mqtt: MQTT integrations support'
'python-pyserial: Arduino/serial device support')
conflicts=('platypush-git')
options=(!strip)
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/BlackLight/${pkgname}/archive/v${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://git.platypush.tech/${pkgname}/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
sha512sums=('182a7087bbbb01dfc3b4c76439f8cf215b58248b935b2a5924a85753ab4adf5224049935fb7980a03d0a14627ae11301cc43cb06229127f674c1ae828cb3f840')
package() {