summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Manganiello2021-10-11 00:53:54 +0200
committerFabio Manganiello2021-10-11 00:53:54 +0200
commit4404765bec7d90f0ae06c112cc9edee80318a23c (patch)
treee814bdc45ef2062c9e348e32db93232fa20834a6
parent2d039a985821b4da9c8b2329e20527ac813e50ed (diff)
downloadaur-4404765bec7d90f0ae06c112cc9edee80318a23c.tar.gz
Using proper conventions for AUR git packages
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d231f4ad4b76..371466d5b921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=platypush-git
pkgver=0.22.3.r0.a5f1dc26
-pkgrel=1
+pkgrel=2
pkgdesc="Universal multi-platform command executor and automation manager"
arch=('any')
license=('MIT')
url="https://git.platypush.tech/platypush/platypush"
+makedepends=('git')
depends=('python' 'python-yaml' 'redis' 'python-redis' 'python-requests' 'python-sqlalchemy' 'python-websockets' 'python-websocket-client' 'python-wheel' 'python-flask' 'python-pip' 'python-dateutil' 'python-frozendict' 'python-bcrypt' 'python-zeroconf' 'python-pyjwt' 'python-croniter' 'python-marshmallow' 'python-pytz')
optdepends=('python-paho-mqtt: MQTT integrations support'
'python-pybluez: Bluetooth support'
@@ -18,15 +19,15 @@ optdepends=('python-paho-mqtt: MQTT integrations support'
conflicts=('platypush')
provides=('platypush')
options=(!strip)
-source=("platypush.tar.gz::https://git.platypush.tech/platypush/platypush/-/archive/master/platypush-master.tar.gz")
-sha512sums=('15c21a15ed06b48ac33973831c56cea1fa908c328ca5679b08e77b1e161d17ef264e12bb425f5dbbf45bc4eba63def9f6ca374e3c38b69cf4e5ee6841b4789bc')
+source=("git+https://git.platypush.tech/platypush/platypush")
+sha512sums=('SKIP')
package() {
- cd "${srcdir}/platypush-master"
+ cd "${srcdir}/platypush"
python3 setup.py install --root="${pkgdir}/" --optimize=1
install -m755 -d "${pkgdir}/usr/lib/systemd/user"
- install -m644 "${srcdir}/platypush-master/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
+ install -m644 "${srcdir}/platypush/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
echo
echo