summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Manganiello2020-07-25 01:16:51 +0200
committerFabio Manganiello2020-07-25 01:16:51 +0200
commit73f1764bd6689af8526f7ec62573acd71408428a (patch)
tree9c1c1fc73010909fc18982ae35d8d57428146aa2
downloadaur-73f1764bd6689af8526f7ec62573acd71408428a.tar.gz
Created platypush-git package
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae684b159484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = platypush-git
+ pkgdesc = Universal multi-platform command executor and automation manager
+ pkgver = 0.12.10.r0.cabc1542
+ pkgrel = 1
+ url = https://github.com/BlackLight/platypush
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-yaml
+ depends = redis
+ depends = python-redis
+ depends = python-requests
+ depends = python-sqlalchemy
+ depends = python-websockets
+ depends = python-websocket-client
+ depends = python-wheel
+ depends = python-flask
+ depends = python-pip
+ depends = python-dateutil
+ depends = python-frozendict
+ depends = python-bcrypt
+ optdepends = python-paho-mqtt: MQTT integrations support
+ optdepends = python-pybluez: Bluetooth support
+ optdepends = gattlib: Low-energy Bluetooth devices support
+ optdepends = python-paramiko: SSH support
+ optdepends = python-croniter: Platypush cron support
+ optdepends = python-pyserial: Arduino/serial device support
+ conflicts = platypush
+ options = !strip
+ source = platypush.tar.gz::https://github.com/BlackLight/platypush/archive/master.tar.gz
+ sha512sums = 699f083dc11f4ea5929588d99f32789ecbb9f113dcfc2b63fbc001f0cd550dc5bd34b3fe31e229980e22bc519a9b43615d6ba2c767f8866b80f829810a32da89
+
+pkgname = platypush-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8a78eaf132c7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+platypush-*.tar.zst
+platypush-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9f7c2cd4145
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Fabio Manganiello <info@fabiomanganiello.com>
+
+_pkgname=platypush
+pkgname=${_pkgname}-git
+pkgver=0.12.10.r0.cabc1542
+pkgrel=1
+pkgdesc="Universal multi-platform command executor and automation manager"
+arch=('any')
+license=('MIT')
+url="https://github.com/BlackLight/platypush"
+depends=('python' 'python-yaml' 'redis' 'python-redis' 'python-requests' 'python-sqlalchemy' 'python-websockets' 'python-websocket-client' 'python-wheel' 'python-flask'
+ 'python-pip' 'python-dateutil' 'python-frozendict' 'python-bcrypt')
+optdepends=('python-paho-mqtt: MQTT integrations support'
+ 'python-pybluez: Bluetooth support'
+ 'gattlib: Low-energy Bluetooth devices support'
+ 'python-paramiko: SSH support'
+ 'python-croniter: Platypush cron support'
+ 'python-pyserial: Arduino/serial device support')
+conflicts=('platypush')
+options=(!strip)
+source=("${_pkgname}.tar.gz::https://github.com/BlackLight/${_pkgname}/archive/master.tar.gz")
+sha512sums=('699f083dc11f4ea5929588d99f32789ecbb9f113dcfc2b63fbc001f0cd550dc5bd34b3fe31e229980e22bc519a9b43615d6ba2c767f8866b80f829810a32da89')
+
+package() {
+ cd "${srcdir}/${_pkgname}-master"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -m755 -d "${pkgdir}/usr/lib/systemd/user"
+ install -m644 "${srcdir}/${_pkgname}-master/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
+
+ echo
+ echo
+ echo ---------------------------------------------
+ echo You can start the Platypush service through
+ echo systemctl --user start platypush.
+ echo
+ echo Remember to enable/start the Redis service
+ echo before starting Platypush.
+ echo ---------------------------------------------
+ echo
+ echo
+}
+