summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Manganiello2024-05-21 02:48:42 +0200
committerFabio Manganiello2024-05-21 02:48:42 +0200
commitb2a35e327f79445120c984789de628a65946779f (patch)
treee4867c3ca5e0d9cd227ddff32ed334cdacc43f5e
parenta33016279fc250f16664fa1a25d0dc3f9b4ec6ec (diff)
downloadaur-b2a35e327f79445120c984789de628a65946779f.tar.gz
Added configuration files and workdir preparation
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD40
2 files changed, 27 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5b6f41bc295..1a839c64a907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = platypush-git
- pkgdesc = Universal multi-platform command executor and automation manager
+ pkgdesc = A general-purpose, event-driven, plugin-based platform for automation-as-code
pkgver = 0.50.3.r985.g4038ef3b
pkgrel = 1
- url = https://git.platypush.tech/platypush/platypush
+ url = https://platypush.tech
arch = any
license = MIT
makedepends = git
@@ -94,10 +94,11 @@ pkgbase = platypush-git
optdepends = python-watchdog: File monitor support
optdepends = python-weasyprint: PDF generation support
optdepends = pyzbar: QR code and barcodes integration
- optdepends = youtube-dl: Support for downloading/streaming YouTube videos, as well as other video platforms
+ optdepends = yt-dlp: Support for downloading/streaming YouTube videos, as well as other video platforms
provides = platypush
conflicts = platypush
options = !strip
+ backup = etc/platypush/config.yaml
source = master.tar.gz::https://git.platypush.tech/platypush/platypush/archive/master.tar.gz
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 26cdd33bfc58..36452efb8b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,13 @@
pkgname=platypush-git
pkgver=0.50.3.r985.g4038ef3b
pkgrel=1
-pkgdesc="Universal multi-platform command executor and automation manager"
+pkgdesc="A general-purpose, event-driven, plugin-based platform for automation-as-code"
arch=('any')
license=('MIT')
-url="https://git.platypush.tech/platypush/platypush"
+backup=(
+ 'etc/platypush/config.yaml'
+)
+url="https://platypush.tech"
makedepends=('git')
depends=(
'python'
@@ -100,7 +103,7 @@ optdepends=(
'python-watchdog: File monitor support'
'python-weasyprint: PDF generation support'
'pyzbar: QR code and barcodes integration'
- 'youtube-dl: Support for downloading/streaming YouTube videos, as well as other video platforms'
+ 'yt-dlp: Support for downloading/streaming YouTube videos, as well as other video platforms'
)
conflicts=('platypush')
@@ -113,19 +116,22 @@ package() {
cd "${srcdir}/platypush"
PYTHONDONTWRITEBYTECODE=1 python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -m750 -d "${pkgdir}/var/lib/platypush"
+ install -m755 -d "${pkgdir}/usr/lib/systemd/system"
install -m755 -d "${pkgdir}/usr/lib/systemd/user"
- install -m644 "${srcdir}/platypush/examples/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user"
-
- echo
- echo
- echo ---------------------------------------------
- echo You can start the Platypush service through
- echo systemctl --user start platypush.
- echo
- echo Remember to enable/start the Redis service
- echo before starting Platypush.
- echo ---------------------------------------------
- echo
- echo
+ install -m644 "${srcdir}/platypush/platypush/config/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/user/platypush.service"
+ install -m644 "${srcdir}/platypush/platypush/config/systemd/platypush.service" "${pkgdir}/usr/lib/systemd/system/platypush.service"
+ sed -i "${pkgdir}/usr/lib/systemd/system/platypush.service" -r \
+ -e 's/^#\s*Requires=(.*)/Requires=\1/' \
+ -e 's/^\[Service\]$/\[Service\]\
+User=platypush\
+Group=platypush\
+WorkingDirectory=\/var\/lib\/platypush\
+Environment="PLATYPUSH_CONFIG=\/etc\/platypush\/config.yaml"\
+Environment="PLATYPUSH_WORKDIR=\/var\/lib\/platypush"/'
+ install -m750 -d "${pkgdir}/etc/platypush"
+ install -m750 -d "${pkgdir}/etc/platypush/scripts"
+ install -m644 "${srcdir}/platypush/platypush/config/config.yaml" "${pkgdir}/etc/platypush/config.yaml"
+ install -Dm644 "${srcdir}/platypush/platypush/config/systemd/platypush-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/platypush.conf"
+ install -Dm644 "${srcdir}/platypush/platypush/config/systemd/platypush-tmpfile.conf" "${pkgdir}/usr/lib/tmpfiles.d/platypush.conf"
}
-