summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorprofessorkaos642016-09-19 20:15:14 -0400
committerprofessorkaos642016-09-19 20:15:14 -0400
commit008a5344d6ce81610e494c8411e0e8e2becb7901 (patch)
tree8f10b084bfc005cc596e81be7a22e397b35a7792
downloadaur-008a5344d6ce81610e494c8411e0e8e2becb7901.tar.gz
initial upload
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD43
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2829bf1b902a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = play-emu-git
+ pkgdesc = Experimental Playstation 2 emulation (WIP!)
+ pkgver = r3.462d986
+ pkgrel = 1
+ url = https://github.com/jpd002
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = openal
+ depends = qt5-base
+ depends = zlib
+ source = Play-Build::git+https://github.com/jpd002/Play-Build.git
+ md5sums = SKIP
+
+pkgname = play-emu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fd089e772dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer : Michael DeGuzis <mdeguzis@gmail.com>
+
+pkgname=play-emu-git
+_gitname=Play-Build
+pkgver=r3.462d986
+pkgrel=1
+pkgdesc="Experimental Playstation 2 emulation (WIP!)"
+arch=('i686' 'x86_64')
+url="https://github.com/jpd002"
+license=('GPL')
+makedepends=('git')
+depends=('openal' 'qt5-base' 'zlib')
+source=('Play-Build::git+https://github.com/jpd002/Play-Build.git')
+md5sums=('SKIP')
+
+pkgver() {
+
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare () {
+
+ cd $_gitname
+ git submodule init
+ git submodule update
+
+}
+
+build() {
+
+ cd $_gitname/Play/build_unix
+ ./build.sh
+
+}
+
+package() {
+
+ install -d $pkgdir/usr/bin
+ install -m755 $srcdir/$_gitname/Play/build_unix/build-ui/Play-Ui $pkgdir/usr/bin/play
+
+}