summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-08-01 22:33:10 +0200
committerFabioLolix2021-08-01 22:33:10 +0200
commit9537a8b68dabfed8197ad5b8c5850b49398f2834 (patch)
tree2067c88bdac9cca066db0597a6b03d9c3e9757e5
parent27785a61feae5cbb409b51713c1eafde00796a38 (diff)
downloadaur-9537a8b68dabfed8197ad5b8c5850b49398f2834.tar.gz
it compile again
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 114cb0f3b9fb..4409b1ba0453 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = play-emu-git
pkgdesc = Play! is an experimental Playstation 2 emulator.
- pkgver = 0.42.r14.gd27ce484
+ pkgver = 0.42.r60.gf7acc8d7
pkgrel = 1
url = https://purei.org/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 64bfbb14f24c..d34cbee3778f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
-# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
pkgname=play-emu-git
-pkgver=0.42.r14.gd27ce484
+pkgver=0.42.r60.gf7acc8d7
pkgrel=1
pkgdesc="Play! is an experimental Playstation 2 emulator."
arch=(x86_64)
@@ -29,10 +29,7 @@ sha256sums=('SKIP'
pkgver() {
cd "${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare () {
@@ -58,7 +55,7 @@ prepare () {
build() {
cd "${pkgname%-git}/build"
- cmake .. -G"Ninja"
+ cmake .. -Wno-dev -G"Ninja"
cmake --build . --config Release
}