summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-05-23 15:20:19 +0200
committerFabioLolix2020-05-23 15:20:19 +0200
commita7f75a041c21bf0c04014f30da4adb0a049af88e (patch)
treed2c304b315994ccc31f704893dd2ff531be5241f
parent7cbc06d1b0e9f7417bb84c78b0f20cc7e40bf4bc (diff)
downloadaur-a7f75a041c21bf0c04014f30da4adb0a049af88e.tar.gz
revision
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD86
-rw-r--r--play-emu.desktop9
-rw-r--r--play.pngbin5804 -> 0 bytes
4 files changed, 77 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da0f079031c2..d6ca2cde1fc2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,33 @@
pkgbase = play-emu-git
pkgdesc = Play! is an experimental Playstation 2 emulator.
- pkgver = r3.462d986
- pkgrel = 4
- url = https://github.com/jpd002
- arch = i686
+ pkgver = r5687.5fead001
+ pkgrel = 1
+ url = https://purei.org/
arch = x86_64
- license = GPL
+ license = MIT
makedepends = git
- depends = boost
- depends = cmake
- depends = glew
- depends = mysql++
- depends = openal
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = qt5-x11extras
depends = qt5-base
- depends = zlib
- source = Play-Build::git+https://github.com/jpd002/Play-Build.git
- source = play-emu.desktop
- source = play.png
- md5sums = SKIP
- md5sums = 59e7114de681f2f96730697cde4f4595
- md5sums = 2c6db31d8119437e5af6fa95b4c1fb8f
+ depends = openal
+ depends = glew
+ source = play-emu::git+https://github.com/jpd002/Play-
+ source = git+https://github.com/jpd002/Play-Dependencies.git
+ source = git+https://github.com/jpd002/Play--Framework.git
+ source = git+https://github.com/jpd002/Play--CodeGen.git
+ source = git+https://github.com/jpd002/Nuanceur.git
+ source = git+https://github.com/jpd002/boost-cmake.git
+ source = git+https://github.com/rs/SDWebImage.git
+ source = git+https://github.com/gulrak/filesystem.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = play-emu-git
diff --git a/PKGBUILD b/PKGBUILD
index 396864c806b7..9265967f0008 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,71 @@
-# Maintainer : Michael DeGuzis <mdeguzis@gmail.com>
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
pkgname=play-emu-git
-_gitname=Play-Build
-pkgver=r3.462d986
-pkgrel=4
+pkgver=r5687.5fead001
+pkgrel=1
pkgdesc="Play! is an experimental Playstation 2 emulator."
-arch=('i686' 'x86_64')
-url="https://github.com/jpd002"
-license=('GPL')
-makedepends=('git')
-depends=('boost' 'cmake' 'glew' 'mysql++' 'openal'
- 'qt5-base' 'zlib')
-source=('Play-Build::git+https://github.com/jpd002/Play-Build.git'
- 'play-emu.desktop'
- 'play.png')
-md5sums=('SKIP'
- '59e7114de681f2f96730697cde4f4595'
- '2c6db31d8119437e5af6fa95b4c1fb8f')
+arch=(x86_64)
+url="https://purei.org/"
+license=(MIT)
+depends=(qt5-base openal glew)
+makedepends=(git cmake ninja qt5-x11extras)
+source=("${pkgname%-git}::git+https://github.com/jpd002/Play-"
+ "git+https://github.com/jpd002/Play-Dependencies.git"
+ "git+https://github.com/jpd002/Play--Framework.git"
+ "git+https://github.com/jpd002/Play--CodeGen.git"
+ "git+https://github.com/jpd002/Nuanceur.git"
+ "git+https://github.com/jpd002/boost-cmake.git"
+ "git+https://github.com/rs/SDWebImage.git"
+ "git+https://github.com/gulrak/filesystem.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
-
- cd $_gitname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare () {
+ cd "${pkgname%-git}"
- cd $_gitname
git submodule init
+ git config 'submodule.deps/Dependencies.url' "${srcdir}/Play-Dependencies"
+ git config 'submodule.deps/Framework.url' "${srcdir}/Play--Framework"
+ git config 'submodule.deps/CodeGen.url' "${srcdir}/Play--CodeGen"
+ git config 'submodule.deps/Nuanceur.url' "${srcdir}/Nuanceur"
git submodule update
+ install -d build
+
+ cd "${srcdir}/${pkgname%-git}"/deps/Dependencies
+
+ git submodule init
+ git config 'submodule.boost-cmake.url' "${srcdir}/boost-cmake"
+ git config 'submodule.SDWebImage.url' "${srcdir}/SDWebImage"
+ git config 'submodule.ghc_filesystem.url' "${srcdir}/filesystem"
+ git submodule update
}
build() {
-
- cd $_gitname/Play/build_unix
- ./build.sh
-
+ cd "${pkgname%-git}/build"
+ cmake .. -G"Ninja"
+ cmake --build . --config Release
}
package() {
-
- install -d $pkgdir/usr/bin
- install -d $pkgdir/usr/share/pixmaps
- install -d $pkgdir/usr/share/applications
-
- install -m755 $srcdir/$_gitname/Play/build_unix/build-ui/Play-Ui $pkgdir/usr/bin/play-emu
- install -m755 play.png $pkgdir/usr/share/pixmaps/play.png
- install -m755 play-emu.desktop $pkgdir/usr/share/applications/play-emu.desktop
-
+ cd "${pkgname%-git}"
+ install -Dm755 build/Source/ui_qt/Play "${pkgdir}"/usr/bin/play-emu
+ install -D icons/icon.svg "${pkgdir}"/usr/share/pixmaps/play.svg
+ install -D installer_unix/Play.desktop "${pkgdir}"/usr/share/applications/play-emu.desktop
+ install -D License.txt "${pkgdir}/usr/share/licenses/${pkgname}"/License.txt
}
diff --git a/play-emu.desktop b/play-emu.desktop
deleted file mode 100644
index 0427f8b406e1..000000000000
--- a/play-emu.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Play!
-GenericName=Play!
-X-GNOME-FullName=Playstation 2 Emulator.
-Comment=Playstation 2 Emulator
-Exec=play-emu
-Icon=/usr/share/pixmaps/play.png
-Terminal=false
-Type=Game;ActionGame;
diff --git a/play.png b/play.png
deleted file mode 100644
index 972c72e01e85..000000000000
--- a/play.png
+++ /dev/null
Binary files differ