summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Schneider2018-06-11 00:28:12 +0200
committerThomas Schneider2018-06-11 00:28:12 +0200
commit7e7e1b0fa873b5ac3ad65ed3097198c596d84f6a (patch)
treecdd346660a67b5e2e27fa5fab220eb0d768d366a
downloadaur-7e7e1b0fa873b5ac3ad65ed3097198c596d84f6a.tar.gz
initial fixed play-emu package using the ninja build system
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
-rw-r--r--play-emu.desktop9
-rw-r--r--play.pngbin0 -> 5804 bytes
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8729eb56b379
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = play-emu-ninja-git
+ pkgdesc = Play! is an experimental Playstation 2 emulator. (build using ninja)
+ pkgver = r3.462d986
+ pkgrel = 4
+ url = https://github.com/jpd002
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = ninja
+ depends = cmake
+ depends = glew
+ depends = mysql++
+ depends = openal
+ depends = qt5-base
+ depends = zlib
+ conflicts = play-emu-git
+ replaces = play-emu-git
+ source = Play-Build::git+https://github.com/jpd002/Play-Build.git
+ source = play-emu.desktop
+ source = play.png
+ md5sums = SKIP
+ md5sums = 59e7114de681f2f96730697cde4f4595
+ md5sums = 2c6db31d8119437e5af6fa95b4c1fb8f
+
+pkgname = play-emu-ninja-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac160ae2b624
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Thomas Schneider <maxmusterm@gmail.com>
+# Contributor: Michael DeGuzis <mdeguzis@gmail.com>
+
+pkgname=play-emu-ninja-git
+_gitname=Play-Build
+pkgver=r3.462d986
+pkgrel=4
+pkgdesc="Play! is an experimental Playstation 2 emulator. (build using ninja)"
+arch=('i686' 'x86_64')
+url="https://github.com/jpd002"
+license=('GPL')
+makedepends=('git' 'ninja')
+conflicts=('play-emu-git')
+replaces=('play-emu-git')
+depends=('cmake' 'glew' 'mysql++' 'openal'
+ 'qt5-base' 'zlib')
+source=('Play-Build::git+https://github.com/jpd002/Play-Build.git'
+ 'play-emu.desktop'
+ 'play.png')
+md5sums=('SKIP'
+ '59e7114de681f2f96730697cde4f4595'
+ '2c6db31d8119437e5af6fa95b4c1fb8f')
+
+pkgver() {
+
+ cd $_gitname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+prepare () {
+ cd $_gitname
+ git submodule update -q --init --recursive
+ git submodule foreach "git checkout -q master"
+ cd Dependencies
+ git submodule update --init
+}
+
+build() {
+ cd $_gitname/Play/
+ mkdir build
+ cd build
+ cmake .. -G"Ninja"
+ cmake --build . --config Release
+}
+
+package() {
+ install -d $pkgdir/usr/bin
+ install -d $pkgdir/usr/share/pixmaps
+ install -d $pkgdir/usr/share/applications
+ install -m755 $srcdir/$_gitname/Play/build/Source/ui_unix/Play $pkgdir/usr/bin/play-emu
+ install -m755 play.png $pkgdir/usr/share/pixmaps/play.png
+ install -m755 play-emu.desktop $pkgdir/usr/share/applications/play-emu.desktop
+}
+
diff --git a/play-emu.desktop b/play-emu.desktop
new file mode 100644
index 000000000000..0427f8b406e1
--- /dev/null
+++ b/play-emu.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Play!
+GenericName=Play!
+X-GNOME-FullName=Playstation 2 Emulator.
+Comment=Playstation 2 Emulator
+Exec=play-emu
+Icon=/usr/share/pixmaps/play.png
+Terminal=false
+Type=Game;ActionGame;
diff --git a/play.png b/play.png
new file mode 100644
index 000000000000..972c72e01e85
--- /dev/null
+++ b/play.png
Binary files differ