summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2018-02-05 14:00:13 -0800
committerJonathan Knapp2018-02-05 14:00:13 -0800
commit8e2bfb33e77b737006379f2d44fe7a013021ff99 (patch)
treead48385c2283842850e8ad6a83d93a658e78abfe
downloadaur-8e2bfb33e77b737006379f2d44fe7a013021ff99.tar.gz
Initial build
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..925c108833bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = play-with-mpv-git
+ pkgdesc = Chrome extension and python server that allows you to play videos in webpages with MPV instead.
+ pkgver = 0.0.5.718a021
+ pkgrel = 1
+ url = https://github.com/Thann/play-with-mpv
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ depends = python
+ depends = youtube-dl
+ depends = mpv
+ optdepends = peerflix
+ provides = play-with-mpv
+ conflicts = play-with-mpv
+ source = play-with-mpv-git::git+https://github.com/Thann/play-with-mpv.git
+ md5sums = SKIP
+
+pkgname = play-with-mpv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8801e00c121c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Jonathan Knapp <jaknapp8+aur@gmail.com>
+# URL: https://github.com/Thann/play-with-mpv
+# Upstream: https://github.com/Thann/play-with-mpv
+
+pkgname=play-with-mpv-git
+pkgver=0.0.5.718a021
+pkgrel=1
+pkgdesc='Chrome extension and python server that allows you to play videos in webpages with MPV instead.'
+arch=('any')
+url='https://github.com/Thann/play-with-mpv'
+license=('MIT')
+depends=('python' 'youtube-dl' 'mpv')
+optdepends=('peerflix')
+makedepends=('git' 'npm')
+provides=('play-with-mpv')
+conflicts=('play-with-mpv')
+source=("$pkgname::git+https://github.com/Thann/play-with-mpv.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo "$(python setup.py --version).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}