summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Knapp2021-08-06 12:35:43 -0700
committerJonathan Knapp2021-08-06 21:57:13 -0700
commitd75f03b7e680cc9cf4f1ef133dce1ae6dba202f2 (patch)
treecbfbe675bf7bf63947d0882758cf35c1d4a9c919
parent609909ad2e5fc7f03567668007d4588f8bf8fad5 (diff)
downloadaur-d75f03b7e680cc9cf4f1ef133dce1ae6dba202f2.tar.gz
Add systemd unit + python-pip dep
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--play-with-mpv.service10
3 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3c7775d2899..472a0d776013 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = play-with-mpv-git
pkgdesc = Chrome extension and python server that allows you to play videos in webpages with MPV instead.
- pkgver = 0.1.0.post3+g0c27cd4
+ pkgver = 0.1.0.post9+g07a9c1d
pkgrel = 1
url = https://github.com/Thann/play-with-mpv
arch = any
@@ -9,6 +9,7 @@ pkgbase = play-with-mpv-git
makedepends = python-setuptools
depends = python
depends = python-wheel
+ depends = python-pip
depends = youtube-dl
depends = mpv
optdepends = peerflix
@@ -16,7 +17,8 @@ pkgbase = play-with-mpv-git
provides = play-with-mpv
conflicts = play-with-mpv
source = play-with-mpv-git::git+https://github.com/Thann/play-with-mpv.git
- md5sums = SKIP
+ source = play-with-mpv.service
+ sha256sums = SKIP
+ sha256sums = 3015d2a2d1c3274096879360ed2f521efc1b233c48fe1a8c836924736d378f50
pkgname = play-with-mpv-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6018d5d09caa..2dfe2fc86b91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,19 +3,19 @@
# Upstream: https://github.com/Thann/play-with-mpv
pkgname=play-with-mpv-git
-pkgver=0.1.0.post3+g0c27cd4
+pkgver=0.1.0.post9+g07a9c1d
pkgrel=1
pkgdesc='Chrome extension and python server that allows you to play videos in webpages with MPV instead.'
arch=('any')
url='https://github.com/Thann/play-with-mpv'
license=('MIT')
-depends=('python' 'python-wheel' 'youtube-dl' 'mpv')
+depends=('python' 'python-wheel' 'python-pip' 'youtube-dl' 'mpv')
optdepends=('peerflix' 'mkchromecast')
makedepends=('git' 'python-setuptools')
provides=('play-with-mpv')
conflicts=('play-with-mpv')
-source=("$pkgname::git+https://github.com/Thann/play-with-mpv.git")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/Thann/play-with-mpv.git" "play-with-mpv.service")
+sha256sums=('SKIP' '3015d2a2d1c3274096879360ed2f521efc1b233c48fe1a8c836924736d378f50')
pkgver() {
cd $pkgname
@@ -26,4 +26,5 @@ package() {
cd "$pkgname"
python setup.py install --root="$pkgdir/" --optimize=1
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 ../play-with-mpv.service "$pkgdir/usr/lib/systemd/user/play-with-mpv.service"
}
diff --git a/play-with-mpv.service b/play-with-mpv.service
new file mode 100644
index 000000000000..cadb219f97bb
--- /dev/null
+++ b/play-with-mpv.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=Daemon to start mpv on command
+# Documentation=man:
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/play-with-mpv
+
+[Install]
+WantedBy=graphical.target