summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2019-07-28 19:39:43 +0200
committerEmmanuel Gil Peyrot2019-07-28 19:39:43 +0200
commit08389b8d4773cd49af7351631a89f16c30c2e1ac (patch)
tree855ced072d5aa63b2f6c9d3f39cc9f323bbee023
parenta8f21845d0ffed89fc2d5bbfbb67c6b5c2eeb877 (diff)
downloadaur-08389b8d4773cd49af7351631a89f16c30c2e1ac.tar.gz
Make a -git version of ./play.it
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 24 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f3852844e93..3f6fc9de813e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
-pkgbase = play.it
- pkgdesc = Easy way to install games on Linux
- pkgver = 2.11.2
+pkgbase = play.it-git
+ pkgdesc = Easy way to install games on Linux - git version
+ pkgver = 2.11.1.r849.g1a4d6b0e
pkgrel = 1
url = https://wiki.dotslashplay.it
arch = any
@@ -12,8 +12,10 @@ pkgbase = play.it
optdepends = icoutils: to manipulate Windows icon files
optdepends = innoextract: to extract some Windows installers
optdepends = unzip: to extract some archives
- source = play.it-2.11.2.tar.gz::https://framagit.org/vv221/play.it/-/archive/2.11.2/play.it-2.11.2.tar.gz
- sha1sums = b5a2dba4d61ea5b77e87714d3e862d48991facba
+ provides = play.it
+ conflicts = play.it
+ source = play.it::git+https://forge.dotslashplay.it/play.it/scripts.git
+ sha1sums = SKIP
-pkgname = play.it
+pkgname = play.it-git
diff --git a/PKGBUILD b/PKGBUILD
index 6cebe00c1806..4ec5d27a9b0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,17 @@
-# Maintainer: Mopi <mopi@dotslashplay.it>
-# Contributor: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+# Contributor: Mopi <mopi@dotslashplay.it>
-pkgname=play.it
-pkgver=2.11.2
+pkgname=play.it-git
+pkgver=2.11.1.r849.g1a4d6b0e
pkgrel=1
-pkgdesc="Easy way to install games on Linux"
+pkgdesc="Easy way to install games on Linux - git version"
arch=('any')
url="https://wiki.dotslashplay.it"
license=('BSD')
depends=('bash')
makedepends=('pandoc')
+provides=('play.it')
+conflicts=('play.it')
optdepends=(
'imagemagick: to convert images between formats'
'libarchive: to extract various archive formats'
@@ -17,16 +19,21 @@ optdepends=(
'innoextract: to extract some Windows installers'
'unzip: to extract some archives'
)
-source=("${pkgname}-${pkgver}.tar.gz::https://framagit.org/vv221/play.it/-/archive/${pkgver}/play.it-${pkgver}.tar.gz")
-sha1sums=('b5a2dba4d61ea5b77e87714d3e862d48991facba')
+source=(play.it::"git+https://forge.dotslashplay.it/play.it/scripts.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd play.it
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd play.it
make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd play.it
make DESTDIR="$pkgdir" prefix="/usr" bindir="/usr/bin" install
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}