summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bell2015-10-22 03:20:04 -0400
committerStephen Bell2015-10-22 03:20:04 -0400
commit1136818eba3b186ea8f6a6010ddc7b4038209ccf (patch)
tree5d167ad826f506ce263fcec195b80b9d0f4ef863
downloadaur-1136818eba3b186ea8f6a6010ddc7b4038209ccf.tar.gz
Initial import
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..018fad1bd361
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = playbox
+ pkgdesc = A growing collection of board games.
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/playbox/
+ arch = x86_64
+ license = Eclipse Public License
+ makedepends = unzip
+ depends = gtk3
+
+pkgname = playbox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4001870088f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Stephen Bell <theredbaron1834 @ yahoo.com>
+pkgname=playbox
+pkgrel=1
+pkgver=1.6.1
+pkgdesc="A growing collection of board games."
+arch=('x86_64')
+url="http://sourceforge.net/projects/playbox/"
+license=('Eclipse Public License')
+depends=('gtk3')
+makedepends=('unzip')
+
+build() {
+
+ msg "Grabbing files...."
+ curl http://sourceforge.net/projects/playbox/files/6/playbox-1.6.1.linux.gtk.x86_64.zip/download -L -o playbox.zip
+ unzip playbox.zip
+
+}
+
+package() {
+ cd "$pkgdir"
+ install -m777 -d "$pkgdir/opt/playbox"
+ cp -r "$srcdir/playbox" "$pkgdir/opt/"
+ mkdir -p "$pkgdir/usr/share/applications/"
+ mkdir -p "$pkgdir/usr/bin/"
+ echo "[Desktop Entry]
+Name=Playbox
+GenericName=Playbox
+Comment=A growing collection of board games.
+Exec=playbox
+Icon=/opt/playbox/icon.xpm
+Terminal=false
+Type=Application
+Categories=Game;" > "$pkgdir/usr/share/applications/playbox.desktop"
+ echo "cd /opt/playbox/
+./playbox -configuration ~/.config/playbox/ " > "$pkgdir/usr/bin/playbox"
+ chmod +x "$pkgdir/usr/bin/playbox"
+}
+