summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Freund2018-10-06 18:42:41 +0200
committerAdrian Freund2018-10-06 18:42:41 +0200
commit7211e68f91bd19b3c3bbd7e1243766033fa35f7d (patch)
tree4a1f3656acdcb4224ea1232a0bd66b33dba4f1cf
parentc32c62f9a3c1c564c722b0b65cb38c8d5101e15e (diff)
downloadaur-7211e68f91bd19b3c3bbd7e1243766033fa35f7d.tar.gz
Updated PKGBUILD to work with new build system
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d2a1d445f06..c510ab17346f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adrian Freund <freundadrian@gmail.com>
pkgname=playerctl-git
_pkgname=playerctl
-pkgver=0.5.0.r0.g9f5cc39
+pkgver=0.6.1.r31.ga3a269a
pkgrel=1
pkgdesc="mpris media player controller and lib for spotify, vlc, audacious, bmp, xmms2, and others."
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://github.com/acrisci/playerctl"
license=('LGPL3')
depends=('glib2' 'gobject-introspection')
optdepends=('python-gobject: python bindings')
-makedepends=('git' 'gtk-doc')
+makedepends=('git' 'gtk-doc' 'meson' 'ninja')
provides=('playerctl')
conflicts=('playerctl')
source=("$_pkgname::git+https://github.com/acrisci/playerctl.git")
@@ -22,11 +22,11 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- ./autogen.sh --prefix=/usr
- make -j1
+ meson --prefix=/usr --libdir=/usr/lib mesonbuild
+ DESTDIR="$pkgdir/" ninja -C mesonbuild
}
package() {
cd "$srcdir/$_pkgname"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir/" ninja -C mesonbuild install
}