summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2022-10-05 19:34:01 +0300
committerIgor Dyatlov2022-10-05 19:34:01 +0300
commit644449b8b62e193140ad068ef15338b217d08ef3 (patch)
treead2c14ac909363cb89809884fb1c2deaf75835e2
downloadaur-644449b8b62e193140ad068ef15338b217d08ef3.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD48
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cd6754ff57f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = playhouse-git
+ pkgdesc = A Playground for HTML/CSS/JavaScript
+ pkgver = 1.0+2+g4b983b7
+ pkgrel = 1
+ url = https://github.com/sonnyp/Playhouse
+ arch = x86_64
+ arch = aarch64
+ license = GPL3
+ checkdepends = appstream-glib
+ makedepends = git
+ makedepends = blueprint-compiler
+ makedepends = meson
+ depends = libadwaita
+ depends = webkit2gtk-5.0
+ depends = gjs
+ provides = playhouse
+ conflicts = playhouse
+ source = git+https://github.com/sonnyp/Playhouse.git
+ source = git+https://github.com/sonnyp/troll.git
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = playhouse-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07dad9082df1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=playhouse-git
+_pkgname=Playhouse
+pkgver=1.0+2+g4b983b7
+_commit=a9947bd8f8691a352a41b6534686ce48c4f6ece4
+pkgrel=1
+pkgdesc="A Playground for HTML/CSS/JavaScript"
+arch=('x86_64' 'aarch64')
+url="https://github.com/sonnyp/Playhouse"
+license=('GPL3')
+depends=('libadwaita' 'webkit2gtk-5.0' 'gjs')
+makedepends=('git' 'blueprint-compiler' 'meson')
+checkdepends=('appstream-glib')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git
+ 'git+https://github.com/sonnyp/troll.git')
+b2sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --tags | sed 's/^v//;s/-/+/g'
+}
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.src/troll.url "$srcdir/troll"
+ git submodule update
+
+ # This is not a Flatpak
+ sed -i 's|app/bin|usr/bin|g' "$srcdir/$_pkgname"/src/meson.build
+}
+
+build() {
+ arch-meson "${_pkgname%-git}" build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ meson install -C build --destdir "$pkgdir"
+}