summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVitalii Rybalko2019-04-29 13:38:19 +0300
committerVitalii Rybalko2019-04-29 13:38:19 +0300
commitb2f3c60a63c5ea877e0a3b36b09c4a2f9d853078 (patch)
tree625890b29368a52ec8b780d328437ba0dee00270
downloadaur-b2f3c60a63c5ea877e0a3b36b09c4a2f9d853078.tar.gz
add PKGNUILD and .SRCINFO
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD59
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9850547bdbdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = playkey-linux
+ pkgdesc = Client for game streaming service playkey.net
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.playkey.net
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = innoextract
+ depends = chromium
+ depends = wine
+ depends = python3
+ depends = winetricks
+ depends = openal
+ depends = lib32-openal
+ provides = playkey-linux
+ options = !strip
+ source_x86_64 = https://static.playkey.net/clientdownload.aspx?file=windows-desktop/Release/PlaykeySetup.exe&name=PlaykeySetup.exe
+ source_x86_64 = git+https://github.com/vilkoz/playkey-linux-launcher.git
+ sha256sums_x86_64 = 65588718d0d90632414e6b36a3a9f55bf66bc82fd38bc6841b68b499d67f6ba1
+ sha256sums_x86_64 = SKIP
+
+pkgname = playkey-linux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a255d48b9004
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Vitalii Rybalko <vilko dot a at gmail dot com>
+
+pkgname=playkey-linux
+pkgver=1.0
+pkgrel=1
+pkgdesc='Client for game streaming service playkey.net'
+arch=('x86_64')
+url='https://www.playkey.net'
+license=('custom')
+options=('!strip')
+provides=('playkey-linux')
+conflicts=()
+depends=(
+ 'chromium'
+ 'wine'
+ 'python3'
+ 'winetricks'
+ 'openal'
+ 'lib32-openal'
+)
+makedepends=(
+ 'git'
+ 'innoextract'
+)
+install=
+source_x86_64=(
+ 'https://static.playkey.net/clientdownload.aspx?file=windows-desktop/Release/PlaykeySetup.exe&name=PlaykeySetup.exe'
+ 'git+https://github.com/vilkoz/playkey-linux-launcher.git'
+)
+sha256sums_x86_64=(
+ '65588718d0d90632414e6b36a3a9f55bf66bc82fd38bc6841b68b499d67f6ba1'
+ 'SKIP'
+)
+
+prepare() {
+ msg2 'Extracting PlaykeySetup.exe'
+ innoextract 'PlaykeySetup.exe&name=PlaykeySetup.exe'
+}
+
+package() {
+ msg2 'Creating installation folder'
+ install -d -m755 $pkgdir/usr/share/playkey-linux
+
+ msg2 'Copying windows binaries'
+ cp -ra app/* $pkgdir/usr/share/playkey-linux
+ find $pkgdir/usr/share/playkey-linux -type d -exec chmod 755 "{}" \;
+ find $pkgdir/usr/share/playkey-linux -type f -exec chmod 644 "{}" \;
+
+ msg2 'Copying playkey-linux-launcher scripts'
+ install playkey-linux-launcher/xdg-open $pkgdir/usr/share/playkey-linux
+ install -d -m755 $pkgdir/usr/bin
+ install -m755 playkey-linux-launcher/playkey-linux $pkgdir/usr/bin
+
+ msg2 'Copying playkey-linux-launcher chrome user-agent extension'
+ install -d -m755 $pkgdir/usr/share/playkey-linux/extension
+ cp -ra playkey-linux-launcher/extension/* $pkgdir/usr/share/playkey-linux/extension/
+ find $pkgdir/usr/share/playkey-linux/extension/ -type f -exec chmod 644 "{}" \;
+}
+