summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Carlier2022-05-15 05:22:56 +0200
committerLaurent Carlier2022-05-15 05:22:56 +0200
commit1f2174942fc25f2300870f009da93a34586a3713 (patch)
tree4250fba5df203eb6361294a53a5b4659b3392867
downloadaur-1f2174942fc25f2300870f009da93a34586a3713.tar.gz
moved from community
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD37
-rw-r--r--PlayOnLinuxUrlHandler.desktop10
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89dfaf903b7d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = playonlinux
+ pkgdesc = GUI for managing Windows programs under linux
+ pkgver = 4.3.4
+ pkgrel = 4
+ url = https://www.playonlinux.com/
+ arch = x86_64
+ license = GPL
+ depends = wine
+ depends = imagemagick
+ depends = xterm
+ depends = wxpython
+ depends = cabextract
+ depends = unzip
+ depends = mesa-utils
+ depends = gnupg
+ depends = icoutils
+ depends = xdg-user-dirs
+ depends = libxmu
+ depends = netcat
+ depends = wget
+ depends = p7zip
+ depends = jq
+ depends = perl
+ options = !strip
+ source = https://www.playonlinux.com/script_files/PlayOnLinux/4.3.4/PlayOnLinux_4.3.4.tar.gz
+ source = PlayOnLinuxUrlHandler.desktop
+ sha256sums = 17c3dfd27962ce5a7a0c014850b33188e203d008c9dc71faa230e35fcada2d05
+ sha256sums = 304d8e998d271383c44acdf386c4664cd65463d5f7f5e3c1c7563fbd8f71a6a8
+
+pkgname = playonlinux
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3b44d23e061
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Laurent Carlier <lordheavym@gmail.com>
+# Contributor: K. Hampf <khampf@users.sourceforge.net>
+# Contributor: Skunnyk <skunnyk@archlinux.fr>
+
+pkgname=playonlinux
+pkgver=4.3.4
+pkgrel=4
+pkgdesc="GUI for managing Windows programs under linux"
+url="https://www.playonlinux.com/"
+license=('GPL')
+depends=('wine' 'imagemagick' 'xterm' 'wxpython' 'cabextract' 'unzip' 'mesa-utils' 'gnupg'
+ 'icoutils' 'xdg-user-dirs' 'libxmu' 'netcat' 'wget' 'p7zip' 'jq' 'perl')
+arch=('x86_64')
+source=(https://www.playonlinux.com/script_files/PlayOnLinux/${pkgver/.0/}/PlayOnLinux_${pkgver/.0/}.tar.gz
+ PlayOnLinuxUrlHandler.desktop)
+options=(!strip)
+sha256sums=('17c3dfd27962ce5a7a0c014850b33188e203d008c9dc71faa230e35fcada2d05'
+ '304d8e998d271383c44acdf386c4664cd65463d5f7f5e3c1c7563fbd8f71a6a8')
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ sed -i "s/libexec/bin/g" Makefile
+
+ make PREFIX=/usr
+ make DESTDIR="${pkgdir}" install
+
+ install -d "${pkgdir}"/usr/share/playonlinux/lang
+ mv -v "${pkgdir}"/usr/share/locale "${pkgdir}"/usr/share/playonlinux/lang/locale
+ chmod 755 "${pkgdir}"/usr/share/playonlinux/lang
+
+ install -m755 "${srcdir}"/PlayOnLinuxUrlHandler.desktop "${pkgdir}"/usr/share/applications/PlayOnLinuxUrlHandler.desktop
+ install -m755 playonlinux-url_handler "${pkgdir}"/usr/bin/playonlinux-url_handler
+ sed -i "s/python /python2 /g" "$pkgdir"/usr/{bin,share/playonlinux}/playonlinux-url_handler
+
+# sed -i "s/ %F//g" $pkgdir/usr/share/applications/playonlinux.desktop
+}
diff --git a/PlayOnLinuxUrlHandler.desktop b/PlayOnLinuxUrlHandler.desktop
new file mode 100644
index 000000000000..7d7970b25995
--- /dev/null
+++ b/PlayOnLinuxUrlHandler.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=PlayOnLinux URL handler
+Comment=PlayOnLinux URL handler
+Type=Application
+Exec=/usr/share/playonlinux/playonlinux-url_handler %U
+Icon=playonlinux
+NoDisplay=true
+MimeType=x-scheme-handler/playonlinux;x-scheme-handler/playonmac