summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Engledow2015-06-30 16:15:22 +0100
committerSteve Engledow2015-06-30 16:15:22 +0100
commit57762b8db8acc5122f04b51dc85da76484e5162e (patch)
tree1234c93a4fec11f586807316d9667fc47546f615
downloadaur-57762b8db8acc5122f04b51dc85da76484e5162e.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ca3d5b08274
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = please
+ pkgdesc = A command line utility that makes it easy to integrate web services into your shell scripts
+ pkgver = 0.4.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = MIT
+ source_i686 = please-i686::https://github.com/stilvoid/please/releases/download/v0.4.0/please-linux-i386
+ md5sums_i686 = 695e5519ef51e469cc65110adc4b07ec
+ source_x86_64 = please-x86_64::https://github.com/stilvoid/please/releases/download/v0.4.0/please-linux-amd64
+ md5sums_x86_64 = a39af638db0660adb5c86d0eb3a9e810
+
+pkgname = please
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5adf84e2285
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Steve Engledow <steve at offend dot me dot uk>
+pkgname=please
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A command line utility that makes it easy to integrate web services into your shell scripts"
+arch=('i686' 'x86_64')
+url=""
+license=('MIT')
+install=
+changelog=
+source=($pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums_i686=('695e5519ef51e469cc65110adc4b07ec')
+md5sums_x86_64=('a39af638db0660adb5c86d0eb3a9e810')
+source=()
+source_i686=("please-i686::https://github.com/stilvoid/$pkgname/releases/download/v$pkgver/$pkgname-linux-i386")
+source_x86_64=("please-x86_64::https://github.com/stilvoid/$pkgname/releases/download/v$pkgver/$pkgname-linux-amd64")
+
+package() {
+ install -Dm 755 "${srcdir}/please-$CARCH" "${pkgdir}/usr/bin/please"
+}