summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenry Jenkins2021-08-05 16:36:03 +0100
committerHenry Jenkins2021-08-05 16:36:03 +0100
commit3f47298e6d3580f58509bfcbf102db48fb44f027 (patch)
treefe79cb202dfe41744d2280a64d55a74b525f2901
parentacc0b755268ff29a893fb07d244ace85df781067 (diff)
downloadaur-3f47298e6d3580f58509bfcbf102db48fb44f027.tar.gz
Updating to 16.3.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87d9ea098d8e..c501a7a4554c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = please-bin
pkgdesc = A cross-language build system with an emphasis on high performance, extensibility and reproduceability
- pkgver = 16.2.1
+ pkgver = 16.3.0
pkgrel = 1
url = https://please.build/
arch = x86_64
license = Apache
- source_x86_64 = https://github.com/thought-machine/please/releases/download/v16.2.1/please_16.2.1_linux_amd64.tar.gz
- sha256sums_x86_64 = 7d13b6f4d544e8d6b67b73c96e2f7983110daa5a518baa10e52dce87cbc070f1
+ source_x86_64 = https://github.com/thought-machine/please/releases/download/v16.3.0/please_16.3.0_linux_amd64.tar.gz
+ sha256sums_x86_64 = 0c03f72b68ee31b0a36bd4ab63483ea3e40d863f459352731dae0756f6082045
pkgname = please-bin
diff --git a/PKGBUILD b/PKGBUILD
index fd2112328fa6..6673f51f4f5d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Henry Jenkins <archlinux.org@henryjenkins.com>
pkgname=please-bin
-pkgver=16.2.1
+pkgver=16.3.0
pkgrel=1
pkgdesc="A cross-language build system with an emphasis on high performance, extensibility and reproduceability"
arch=("x86_64")
url="https://please.build/"
license=("Apache")
source_x86_64=("https://github.com/thought-machine/please/releases/download/v${pkgver}/please_${pkgver}_linux_amd64.tar.gz")
-sha256sums_x86_64=("7d13b6f4d544e8d6b67b73c96e2f7983110daa5a518baa10e52dce87cbc070f1")
+sha256sums_x86_64=("0c03f72b68ee31b0a36bd4ab63483ea3e40d863f459352731dae0756f6082045")
package() {
install -d "${pkgdir}/opt/thought-machine"
@@ -17,4 +17,5 @@ package() {
cp -r "${srcdir}/please" "${pkgdir}/opt/thought-machine"
ln -s /opt/thought-machine/please/please "${pkgdir}/usr/bin/please"
+ ln -s /opt/thought-machine/please/please "${pkgdir}/usr/bin/plz"
}