summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Henson2019-12-23 11:13:47 -0700
committerJeff Henson2019-12-23 11:26:50 -0700
commit4a6ab4e6673c96b9ac7743836a4c1afc489a4249 (patch)
treecae15dacaaeae2b7141bae9b4adc8bb7d7cc8bb3
parent10e1c4dc83c0de4b14c8a7b63cf2ffb6a25d2ad1 (diff)
downloadaur-4a6ab4e6673c96b9ac7743836a4c1afc489a4249.tar.gz
Add hack for qt 5.14
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
-rw-r--r--qt5.14.patch17
4 files changed, 30 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 128f92c67d7a..84a158553531 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,9 @@ pkgbase = plex-media-player-git
provides = plex-media-player
conflicts = plex-media-player
source = git+https://github.com/plexinc/plex-media-player.git
+ source = qt5.14.patch
sha256sums = SKIP
+ sha256sums = 28ca2a697ecad89721a88994fbc17467254e9c46162e1c09a37e64e56d29cfc1
pkgname = plex-media-player-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..91399658d5f6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!qt5.14.patch
diff --git a/PKGBUILD b/PKGBUILD
index 06ceaab9095a..31d7603fda65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=plex-media-player-git
pkgver=r1302.e74d341
-pkgrel=1
+pkgrel=2
pkgdesc='Next generation Plex Desktop Client'
arch=('i686' 'x86_64')
license=('GPL')
@@ -11,8 +11,10 @@ provides=('plex-media-player')
conflicts=('plex-media-player')
depends=('mpv' 'libcec' 'sdl2' 'p8-platform' 'protobuf' 'qt5-webengine' 'qt5-x11extras' 'qt5-quickcontrols')
makedepends=('cmake' 'git')
-source=('git+https://github.com/plexinc/plex-media-player.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/plexinc/plex-media-player.git'
+ 'qt5.14.patch')
+sha256sums=('SKIP'
+ '28ca2a697ecad89721a88994fbc17467254e9c46162e1c09a37e64e56d29cfc1')
pkgver() {
cd plex-media-player
@@ -21,6 +23,11 @@ pkgver() {
prepare() {
mkdir -p "${srcdir}/plex-media-player/build"
+
+ # This hack is to fix the build error on qt 5.14. It's probably the worst way
+ # to fix it so hopefully it's fixed upstream soon.
+ cd "${srcdir}/plex-media-player"
+ git apply ../qt5.14.patch
}
build() {
diff --git a/qt5.14.patch b/qt5.14.patch
new file mode 100644
index 000000000000..8fdabb915775
--- /dev/null
+++ b/qt5.14.patch
@@ -0,0 +1,17 @@
+diff --git a/src/player/CodecsComponent.cpp b/src/player/CodecsComponent.cpp
+index fcc89df..5090b86 100644
+--- a/src/player/CodecsComponent.cpp
++++ b/src/player/CodecsComponent.cpp
+@@ -683,9 +683,9 @@ static Downloader::HeaderList getPlexHeaders()
+ Downloader::HeaderList headers;
+ QString auth = SystemComponent::Get().authenticationToken();
+ if (auth.size())
+- headers.append({"X-Plex-Token", auth});
+- headers.append({"X-Plex-Product", WITH_CODECS ? "Plex Media Player" : "openpmp"});
+- headers.append({"X-Plex-Platform", "Konvergo"});
++ headers.append(qMakePair(QString("X-Plex-Token"), auth));
++ headers.append(qMakePair(QString("X-Plex-Product"), QString(WITH_CODECS ? "Plex Media Player" : "openpmp")));
++ headers.append(qMakePair(QString("X-Plex-Platform"), QString("Konvergo")));
+ return headers;
+ }
+