summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Henrique Merces Moreira2017-08-05 02:23:43 -0300
committerCarlos Henrique Merces Moreira2017-08-05 02:23:43 -0300
commit12e3656893d02699c05b99385ac345f7b9478dea (patch)
tree27b86f80237dc43f04147bdf3c0eac3d1c475cd1
parentf7960eca270242b80639f8c5c83fe8846d7fbdf2 (diff)
downloadaur-12e3656893d02699c05b99385ac345f7b9478dea.tar.gz
Fix multi-architecture naming
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fdb2a9d8960f..bff4b1e08528 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plexdrive
pkgdesc = Plexdrive mounts your Google Drive FUSE filesystem (optimized for media playback)
pkgver = 5.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/dweidenfeld/plexdrive
arch = i686
arch = x86_64
@@ -10,17 +10,17 @@ pkgbase = plexdrive
arch = armv7h
arch = aarch64
license = MIT
- source_i686 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
+ source_i686 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-386
md5sums_i686 = ad566b861397499b2bffc5e4ea036394
source_x86_64 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
md5sums_x86_64 = 5ff225e47c72431c440c251d39c6d2ef
- source_arm = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
+ source_arm = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm5
md5sums_arm = 17d84966b994787afb7e8741a2a8f08a
- source_armv6h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
+ source_armv6h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm6
md5sums_armv6h = 611d9b2d6053dd8e8a33952b5e34c6e4
- source_armv7h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
+ source_armv7h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm7
md5sums_armv7h = 4d3691f0ab29dd2ce332d234130d4bfb
- source_aarch64 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
+ source_aarch64 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm64
md5sums_aarch64 = 2af4d2b4596492c52dd0e0f88f542a81
pkgname = plexdrive
diff --git a/PKGBUILD b/PKGBUILD
index 06b2155d3c87..7c18aacfc958 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Carlos Henrique Merces Moreira "chmercesmoreira" <ch.mercesmoreira@gmail.com>
pkgname=plexdrive
pkgver=5.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Plexdrive mounts your Google Drive FUSE filesystem (optimized for media playback)"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/dweidenfeld/plexdrive"
license=('MIT')
-[ "$CARCH" = "i686" ] && _pkgname=plexdrive-linux-386
-[ "$CARCH" = "x86_64" ] && _pkgname=plexdrive-linux-amd64
-[ "$CARCH" = "arm" ] && _pkgname=plexdrive-linux-arm5
-[ "$CARCH" = "armv6h" ] && _pkgname=plexdrive-linux-arm6
-[ "$CARCH" = "armv7h" ] && _pkgname=plexdrive-linux-arm7
-[ "$CARCH" = "aarch64" ] && _pkgname=plexdrive-linux-arm64
-source_i686=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
-source_x86_64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
-source_arm=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
-source_armv6h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
-source_armv7h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
-source_aarch64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$_pkgname"")
+source_i686=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-386")
+source_x86_64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-amd64")
+source_arm=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm5")
+source_armv6h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm6")
+source_armv7h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm7")
+source_aarch64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm64")
md5sums_i686=('ad566b861397499b2bffc5e4ea036394')
md5sums_x86_64=('5ff225e47c72431c440c251d39c6d2ef')
md5sums_arm=('17d84966b994787afb7e8741a2a8f08a')
@@ -26,5 +20,5 @@ md5sums_armv7h=('4d3691f0ab29dd2ce332d234130d4bfb')
md5sums_aarch64=('2af4d2b4596492c52dd0e0f88f542a81')
package () {
- install -m755 "$_pkgname" "$pkgdir/usr/bin/plexdrive"
+ install -m755 "$pkgname"-linux-{386,amd64,arm5,arm6,arm7,arm64} "$pkgdir/usr/bin/plexdrive"
}