summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAxel Gembe2019-07-29 12:13:10 +0700
committerAxel Gembe2019-07-29 12:21:11 +0700
commit1af81ba4875ddc0a473b24472b983d562e3708aa (patch)
treeb1deaa91bdbdeff28ea1285ab0da7f48c5ea65ad
parent2d5303f94e55b192c3395dceb16fbf1540524c4a (diff)
downloadaur-1af81ba4875ddc0a473b24472b983d562e3708aa.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 24 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 221f6d1badf5..6d9c77591de0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,13 @@
pkgbase = plexdrive
- pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.
+ pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem
pkgver = 5.0.0
pkgrel = 1
url = https://github.com/dweidenfeld/plexdrive
- arch = i686
- arch = x86_64
- arch = armv7h
- arch = armv6h
+ arch = any
license = MIT
- makedepends = go
- depends = fuse
- conflicts = plexdrive-bin
- conflicts = plexdrive-git
- conflicts = plexdrive-dev-git
- conflicts = plexdrive-mongodb
- conflicts = plexdrive-mongodb-bin
- conflicts = plexdrive-sqlite
- conflicts = plexdrive-sqlite-bin
+ makedepends = go-pie
+ provides = plexdrive
+ conflicts = plexdrive
source = https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz
sha256sums = 68763993a3da3d8ccd0dc18b3a5db7ab7ad8d03fde2d9be2ef4829e8356225bd
diff --git a/PKGBUILD b/PKGBUILD
index 3c314c155490..7b4fc60ed406 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,30 @@
-# Maintainer: Scott Dickson <scottfoesho AT gmail DOT com>
-
-pkgname=plexdrive
+# Maintainer: Axel Gembe <derago@gmail.com>
+pkgname='plexdrive'
+_pkgname=$pkgname
+pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem'
pkgver=5.0.0
pkgrel=1
-pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.'
-arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url='https://github.com/dweidenfeld/plexdrive'
+arch=('any')
license=('MIT')
-depends=('fuse')
-makedepends=('go')
-conflicts=("plexdrive-bin" "plexdrive-git" "plexdrive-dev-git" "plexdrive-mongodb" "plexdrive-mongodb-bin" "plexdrive-sqlite" "plexdrive-sqlite-bin")
-source=(https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz)
+makedepends=(
+ 'go-pie'
+)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz")
sha256sums=('68763993a3da3d8ccd0dc18b3a5db7ab7ad8d03fde2d9be2ef4829e8356225bd')
-_goroot='/usr/lib/go'
build() {
- mkdir -p plexdrive/src/github.com/dweidenfeld/plexdrive
- cd plexdrive
- export GOROOT="$_goroot"
- GOPATH=$PWD && export GOPATH
- cp ../plexdrive-${pkgver}/*.go .
- mv ../plexdrive-${pkgver}/* src/github.com/dweidenfeld/plexdrive
- go get bazil.org/fuse
- go get github.com/boltdb/bolt
- go get google.golang.org/api/googleapi
- go get golang.org/x/sys/unix
- go get github.com/ogier/pflag
- go get github.com/claudetech/loggo
- go get golang.org/x/net/context
- go get golang.org/x/oauth2
- go build
+ cd "$pkgname-$pkgver"
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $_pkgname .
}
package() {
- install -d ${pkgdir}/usr/bin
- install -Dm755 ${srcdir}/plexdrive/plexdrive ${pkgdir}/usr/bin/
+ cd "$pkgname-$pkgver"
+ install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
}