summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAxel Gembe2019-07-29 12:23:19 +0700
committerAxel Gembe2019-07-29 12:23:19 +0700
commit4907a93319c4231a6780fba737223816587aeffd (patch)
treedd51fe3f07ee36dc487d3a13e2f6aa07f618d8da
parent1af81ba4875ddc0a473b24472b983d562e3708aa (diff)
downloadaur-4907a93319c4231a6780fba737223816587aeffd.tar.gz
Revert "Initial version"
This reverts commit 1af81ba4875ddc0a473b24472b983d562e3708aa.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 41 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d9c77591de0..221f6d1badf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,22 @@
pkgbase = plexdrive
- pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem
+ pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.
pkgver = 5.0.0
pkgrel = 1
url = https://github.com/dweidenfeld/plexdrive
- arch = any
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = armv6h
license = MIT
- makedepends = go-pie
- provides = plexdrive
- conflicts = plexdrive
+ makedepends = go
+ depends = fuse
+ conflicts = plexdrive-bin
+ conflicts = plexdrive-git
+ conflicts = plexdrive-dev-git
+ conflicts = plexdrive-mongodb
+ conflicts = plexdrive-mongodb-bin
+ conflicts = plexdrive-sqlite
+ conflicts = plexdrive-sqlite-bin
source = https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz
sha256sums = 68763993a3da3d8ccd0dc18b3a5db7ab7ad8d03fde2d9be2ef4829e8356225bd
diff --git a/PKGBUILD b/PKGBUILD
index 7b4fc60ed406..3c314c155490 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,38 @@
-# Maintainer: Axel Gembe <derago@gmail.com>
-pkgname='plexdrive'
-_pkgname=$pkgname
-pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem'
+# Maintainer: Scott Dickson <scottfoesho AT gmail DOT com>
+
+pkgname=plexdrive
pkgver=5.0.0
pkgrel=1
+pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.'
+arch=('i686' 'x86_64' 'armv7h' 'armv6h')
url='https://github.com/dweidenfeld/plexdrive'
-arch=('any')
license=('MIT')
-makedepends=(
- 'go-pie'
-)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz")
+depends=('fuse')
+makedepends=('go')
+conflicts=("plexdrive-bin" "plexdrive-git" "plexdrive-dev-git" "plexdrive-mongodb" "plexdrive-mongodb-bin" "plexdrive-sqlite" "plexdrive-sqlite-bin")
+source=(https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz)
sha256sums=('68763993a3da3d8ccd0dc18b3a5db7ab7ad8d03fde2d9be2ef4829e8356225bd')
+_goroot='/usr/lib/go'
build() {
- cd "$pkgname-$pkgver"
- go build \
- -gcflags "all=-trimpath=$PWD" \
- -asmflags "all=-trimpath=$PWD" \
- -ldflags "-extldflags $LDFLAGS" \
- -o $_pkgname .
+ mkdir -p plexdrive/src/github.com/dweidenfeld/plexdrive
+ cd plexdrive
+ export GOROOT="$_goroot"
+ GOPATH=$PWD && export GOPATH
+ cp ../plexdrive-${pkgver}/*.go .
+ mv ../plexdrive-${pkgver}/* src/github.com/dweidenfeld/plexdrive
+ go get bazil.org/fuse
+ go get github.com/boltdb/bolt
+ go get google.golang.org/api/googleapi
+ go get golang.org/x/sys/unix
+ go get github.com/ogier/pflag
+ go get github.com/claudetech/loggo
+ go get golang.org/x/net/context
+ go get golang.org/x/oauth2
+ go build
}
package() {
- cd "$pkgname-$pkgver"
- install -Dm755 $_pkgname "$pkgdir"/usr/bin/$_pkgname
+ install -d ${pkgdir}/usr/bin
+ install -Dm755 ${srcdir}/plexdrive/plexdrive ${pkgdir}/usr/bin/
}