summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Dickson2017-11-29 16:06:52 -0800
committerScott Dickson2017-11-29 16:06:52 -0800
commit77ccf6b6d52c74da15354f768b19c8b44f8bff29 (patch)
treed5ad755602917147645ed53d930f5d8be03191cb
parentcaab063802111a11bf442ea9fa66ce1127d97fd5 (diff)
downloadaur-77ccf6b6d52c74da15354f768b19c8b44f8bff29.tar.gz
First commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD53
2 files changed, 42 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adf69856be84..b6fd79ce2e2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,19 @@
pkgbase = plexdrive
- pkgdesc = Plexdrive mounts your Google Drive FUSE filesystem (optimized for media playback)
+ pkgdesc = Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.
pkgver = 5.0.0
- pkgrel = 6
+ pkgrel = 1
url = https://github.com/dweidenfeld/plexdrive
arch = i686
arch = x86_64
- arch = arm
- arch = armv6h
arch = armv7h
- arch = aarch64
license = MIT
- depends = fuse2
- source_i686 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-386
- md5sums_i686 = ad566b861397499b2bffc5e4ea036394
- source_x86_64 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-amd64
- md5sums_x86_64 = 5ff225e47c72431c440c251d39c6d2ef
- source_arm = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm5
- md5sums_arm = 17d84966b994787afb7e8741a2a8f08a
- source_armv6h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm6
- md5sums_armv6h = 611d9b2d6053dd8e8a33952b5e34c6e4
- source_armv7h = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm7
- md5sums_armv7h = 4d3691f0ab29dd2ce332d234130d4bfb
- source_aarch64 = https://github.com/dweidenfeld/plexdrive/releases/download/5.0.0/plexdrive-linux-arm64
- md5sums_aarch64 = 2af4d2b4596492c52dd0e0f88f542a81
+ makedepends = go
+ depends = fuse
+ conflicts = -bin
+ conflicts = -git
+ conflicts = -dev-git
+ source = https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz
+ md5sums = 4babdf453fd969776a4e3480079ec698
pkgname = plexdrive
diff --git a/PKGBUILD b/PKGBUILD
index d32515257b2a..9db5ba812145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,38 @@
-# Maintainer: Carlos Henrique Merces Moreira "chmercesmoreira" <ch.mercesmoreira@gmail.com>
+# Maintainer: Scott Dickson <scottfoesho@gmail.com>
+
pkgname=plexdrive
pkgver=5.0.0
-pkgrel=6
-pkgdesc="Plexdrive mounts your Google Drive FUSE filesystem (optimized for media playback)"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
-url="https://github.com/dweidenfeld/plexdrive"
+pkgrel=1
+pkgdesc='Plexdrive allows you to mount your Google Drive account as read-only fuse filesystem, with direct delete option on the filesystem.'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/dweidenfeld/plexdrive'
license=('MIT')
-depends=('fuse2')
-source_i686=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-386")
-source_x86_64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-amd64")
-source_arm=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm5")
-source_armv6h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm6")
-source_armv7h=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm7")
-source_aarch64=("https://github.com/dweidenfeld/"$pkgname"/releases/download/"$pkgver"/"$pkgname"-linux-arm64")
-md5sums_i686=('ad566b861397499b2bffc5e4ea036394')
-md5sums_x86_64=('5ff225e47c72431c440c251d39c6d2ef')
-md5sums_arm=('17d84966b994787afb7e8741a2a8f08a')
-md5sums_armv6h=('611d9b2d6053dd8e8a33952b5e34c6e4')
-md5sums_armv7h=('4d3691f0ab29dd2ce332d234130d4bfb')
-md5sums_aarch64=('2af4d2b4596492c52dd0e0f88f542a81')
+depends=('fuse')
+makedepends=('go')
+conflicts=("$_pkgname-bin" "$_pkgname-git" "$_pkgname-dev-git")
+source=(https://github.com/dweidenfeld/plexdrive/archive/5.0.0.tar.gz)
+md5sums=('4babdf453fd969776a4e3480079ec698')
+_goroot='/usr/lib/go'
+
+build() {
+ mkdir -p plexdrive/src/github.com/dweidenfeld/plexdrive
+ cd plexdrive
+ export GOROOT="$_goroot"
+ GOPATH=$PWD && export GOPATH
+ mv ../plexdrive-${pkgver}/main.go .
+ mv ../plexdrive-${pkgver}/* src/github.com/dweidenfeld/plexdrive
+ go get bazil.org/fuse
+ go get github.com/boltdb/bolt
+ go get google.golang.org/api/googleapi
+ go get golang.org/x/sys/unix
+ go get github.com/ogier/pflag
+ go get github.com/claudetech/loggo
+ go get golang.org/x/net/context
+ go get golang.org/x/oauth2
+ go build
+}
-package () {
- install -Dm755 "$pkgname"-linux-* "$pkgdir/usr/bin/plexdrive"
+package() {
+ install -d ${pkgdir}/usr/bin
+ install -Dm755 ${srcdir}/plexdrive/plexdrive ${pkgdir}/usr/bin/
}