summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-09-13 13:23:36 +0200
committerSonic-Y3k2015-09-13 13:23:36 +0200
commit8f144258cb92b9fe5a985e02ff38d2bf7909b3fa (patch)
tree3cba43a8dddc7f5b1a980d474cfd2e334597c5ab
parent6ec45a423dea1a4f92606577be0d0f5cf6eff268 (diff)
downloadaur-8f144258cb92b9fe5a985e02ff38d2bf7909b3fa.tar.gz
Added dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99eae5bbea60..e975dbe63a01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,9 +12,10 @@ pkgbase = plexwatch
depends = perl-time-duration
depends = perl-time-modules
depends = perl-json
+ depends = perl-dbd-sqlite
optdepends = perl-net-twitter: Required ONLY if you use twitter
- optdepends = perl-growl-gntp: Required ONLY if you use GNTP
optdepends = perl-net-oauth: Required ONLY if you use twitter
+ optdepends = perl-growl-gntp: Required ONLY if you use GNTP
optdepends = perl-net-smtp-ssl: Required ONLY if you use Email
optdepends = perl-file-readbackwards: Required ONLY if Client IP Logging is enabled
source = plexWatch.tar.gz::https://github.com/ljunkie/plexWatch/archive/v0.3.3.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index b52316580c4c..3e24c68b2fcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,10 +6,10 @@ pkgdesc="Notify and Log 'Now Playing' and 'Watched' content from a Plex Media Se
arch=('any')
url="https://github.com/ljunkie/plexWatch"
license=('unknown')
-depends=('plex-media-server' 'perl-libwww' 'perl-xml-simple' 'perl-dbi' 'perl-time-duration' 'perl-time-modules' 'perl-json')
+depends=('plex-media-server' 'perl-libwww' 'perl-xml-simple' 'perl-dbi' 'perl-time-duration' 'perl-time-modules' 'perl-json' 'perl-dbd-sqlite')
optdepends=('perl-net-twitter: Required ONLY if you use twitter'
- 'perl-growl-gntp: Required ONLY if you use GNTP'
'perl-net-oauth: Required ONLY if you use twitter'
+ 'perl-growl-gntp: Required ONLY if you use GNTP'
'perl-net-smtp-ssl: Required ONLY if you use Email'
'perl-file-readbackwards: Required ONLY if Client IP Logging is enabled')
source=("plexWatch.tar.gz::${url}/archive/v${pkgver}.tar.gz")
@@ -19,8 +19,6 @@ package() {
cd "${srcdir}/plexWatch-${pkgver}"
install -Dm 777 plexWatch.pl "${pkgdir}/opt/plexWatch/plexWatch.pl"
install -Dm 755 config.pl-dist "${pkgdir}/opt/plexWatch/config.pl"
- mkdir -p "${pkgdir}/usr/bin"
- ln -s /opt/plexWatch/plexWatch.pl "${pkgdir}/usr/bin/plexwatch"
}