summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-09-13 12:47:15 +0200
committerSonic-Y3k2015-09-13 12:47:15 +0200
commit8f24225b142fdbd1608fb14b1386054130bb8116 (patch)
tree04315fe71fe691c895d1ca18b7f587a442ce9361
downloadaur-8f24225b142fdbd1608fb14b1386054130bb8116.tar.gz
Initial import
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..99eae5bbea60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = plexwatch
+ pkgdesc = Notify and Log 'Now Playing' and 'Watched' content from a Plex Media Server + 'Recently Added' (...and more)
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/ljunkie/plexWatch
+ arch = any
+ license = unknown
+ depends = plex-media-server
+ depends = perl-libwww
+ depends = perl-xml-simple
+ depends = perl-dbi
+ depends = perl-time-duration
+ depends = perl-time-modules
+ depends = perl-json
+ optdepends = perl-net-twitter: Required ONLY if you use twitter
+ optdepends = perl-growl-gntp: Required ONLY if you use GNTP
+ optdepends = perl-net-oauth: Required ONLY if you use twitter
+ optdepends = perl-net-smtp-ssl: Required ONLY if you use Email
+ optdepends = perl-file-readbackwards: Required ONLY if Client IP Logging is enabled
+ source = plexWatch.tar.gz::https://github.com/ljunkie/plexWatch/archive/v0.3.3.tar.gz
+ sha256sums = 15cb0eb9f7376ae2f409e9dbb6fa5c5bb5d3549c69fe1e36e48ac016a81c38d4
+
+pkgname = plexwatch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..40c47fa5b33b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+pkgname=plexwatch
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="Notify and Log 'Now Playing' and 'Watched' content from a Plex Media Server + 'Recently Added' (...and more)"
+arch=('any')
+url="https://github.com/ljunkie/plexWatch"
+license=('unknown')
+depends=('plex-media-server' 'perl-libwww' 'perl-xml-simple' 'perl-dbi' 'perl-time-duration' 'perl-time-modules' 'perl-json')
+optdepends=('perl-net-twitter: Required ONLY if you use twitter'
+ 'perl-growl-gntp: Required ONLY if you use GNTP'
+ 'perl-net-oauth: Required ONLY if you use twitter'
+ 'perl-net-smtp-ssl: Required ONLY if you use Email'
+ 'perl-file-readbackwards: Required ONLY if Client IP Logging is enabled')
+source=("plexWatch.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('15cb0eb9f7376ae2f409e9dbb6fa5c5bb5d3549c69fe1e36e48ac016a81c38d4')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm 777 plexWatch.pl "${pkgdir}/opt/plexWatch/plexWatch.pl"
+ install -Dm 755 config.pl-dist "${pkgdir}/opt/plexWatch/config.pl"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -s /opt/plexWatch/plexWatch.pl "${pkgdir}/usr/bin/plexwatch"
+}
+
+