summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-09-13 13:03:47 +0200
committerSonic-Y3k2015-09-13 13:03:47 +0200
commit3b7c198d6ebdd332e792b42a3fb903ee8e08f03d (patch)
tree2c14afa1ff0772f5d4f3dccc277add1d3d81ac0a
downloadaur-3b7c198d6ebdd332e792b42a3fb903ee8e08f03d.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--apache.example.conf18
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dab95e8fb72c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = plexwatchweb
+ pkgdesc = A web front-end for plexWatch.
+ pkgver = 1.5.4.2
+ pkgrel = 1
+ url = https://github.com/ecleese/plexWatchWeb
+ arch = any
+ license = unknown
+ optdepends = php-apache: to use the Apache web server
+ options = !strip
+ backup = etc/webapps/plexWatchWeb/apache.example.conf
+ source = plexwatchweb.tar.gz::https://github.com/ecleese/plexWatchWeb/archive/v1.5.4.2.tar.gz
+ source = apache.example.conf
+ sha256sums = 53670b80bd7d52f8c5dbad3a45de3260d4c981706bea1a686e734139117d257d
+ sha256sums = 3464a757b5e27e3c982220faac1cbd4d1a83650680f3f7b5d99074096dbe05e5
+
+pkgname = plexwatchweb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..931aeb22f1d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+
+pkgname=plexwatchweb
+pkgver=1.5.4.2
+pkgrel=1
+pkgdesc="A web front-end for plexWatch."
+arch=('any')
+url="https://github.com/ecleese/plexWatchWeb"
+license=('unknown')
+optdepends=('php-apache: to use the Apache web server')
+makedepends=()
+options=('!strip')
+backup=('etc/webapps/plexWatchWeb/apache.example.conf')
+source=("$pkgname.tar.gz::${url}/archive/v$pkgver.tar.gz"
+ "apache.example.conf")
+sha256sums=("53670b80bd7d52f8c5dbad3a45de3260d4c981706bea1a686e734139117d257d"
+ "3464a757b5e27e3c982220faac1cbd4d1a83650680f3f7b5d99074096dbe05e5")
+
+prepare() {
+ cd "${srcdir}/plexWatchWeb-${pkgver}"
+ find . -type f -name .gitattributes -delete
+ find . -type f -name .gitkeep -delete
+ find . -type f -name .gitignore -delete
+ find . -type f -name .gitmodules -delete
+ find . -type f -name .travis.yml -delete
+ find . -type d -name .git -exec rm -rf {} \;
+}
+
+package() {
+ # install project
+ install -d ${pkgdir}/usr/share/webapps/
+ cp -a ${srcdir}/plexWatchWeb-${pkgver} ${pkgdir}/usr/share/webapps/plexWatchWeb
+
+ # install apache config file
+ install -d ${pkgdir}/etc/webapps/plexWatchWeb
+ install -m 644 ${srcdir}/apache.example.conf ${pkgdir}/etc/webapps/plexWatchWeb/
+
+ find ${pkgdir}/usr/share/webapps/plexWatchWeb -type f -exec chmod 0644 {} \;
+ find ${pkgdir}/usr/share/webapps/plexWatchWeb -type d -exec chmod 0755 {} \;
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..5e1d44d262cd
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,18 @@
+<IfModule mod_alias.c>
+ Alias /plexWatchWeb /usr/share/webapps/plexWatchWeb/
+</IfModule>
+
+<Directory /usr/share/webapps/plexWatchWeb/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/plexWatchWeb/:/etc/webapps/plexWatchWeb"
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/plexWatchWeb
+ ServerName plexWatchWeb.foo.com
+ ErrorLog /var/log/httpd/plexWatchWeb.foo.info-error_log
+ CustomLog /var/log/httpd/plexWatchWeb.foo.info-access_log common
+</VirtualHost>