summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSonic-Y3k2015-09-18 19:46:11 +0200
committerSonic-Y3k2015-09-18 19:46:11 +0200
commitab1db7ea07d7f57fe02c6e9559e647eb88e3b509 (patch)
tree70604498deb77a3e2adb899f34ac37fd6ac5c651
downloadaur-ab1db7ea07d7f57fe02c6e9559e647eb88e3b509.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--apache.example.conf18
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a91b3a03837d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = plexwatchweb-git
+ pkgdesc = A web front-end for plexWatch.
+ pkgver = r278.16923cc
+ pkgrel = 1
+ url = https://github.com/ecleese/plexWatchWeb
+ arch = any
+ license = unknown
+ depends = php-sqlite
+ optdepends = php-apache: to use the Apache web server
+ optdepends = plexwatch: plexwatchweb backend
+ provides = plexwatchweb
+ conflicts = plexwatchweb
+ replaces = plexwatchweb
+ options = !strip
+ backup = etc/webapps/plexWatchWeb/apache.example.conf
+ source = plexwatchweb-git::git+https://github.com/ecleese/plexWatchWeb.git#branch=dev
+ source = apache.example.conf
+ sha256sums = SKIP
+ sha256sums = ccad38b944e825047d2032541e4df4f2de69a3efcf6d0d0cdd432d00a2915e56
+
+pkgname = plexwatchweb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7fa76915927b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Sonic-Y3k <sonic.y3k@googlemail.com>
+
+pkgname=plexwatchweb-git
+pkgver=r278.16923cc
+pkgrel=1
+pkgdesc="A web front-end for plexWatch."
+arch=('any')
+url="https://github.com/ecleese/plexWatchWeb"
+license=('unknown')
+depends=('php-sqlite')
+optdepends=('php-apache: to use the Apache web server'
+ 'plexwatch: plexwatchweb backend')
+options=('!strip')
+provides=(plexwatchweb)
+replaces=("plexwatchweb")
+conflicts=("plexwatchweb")
+backup=('etc/webapps/plexWatchWeb/apache.example.conf')
+source=("$pkgname::git+${url}.git#branch=dev"
+ "apache.example.conf")
+sha256sums=("SKIP"
+ "ccad38b944e825047d2032541e4df4f2de69a3efcf6d0d0cdd432d00a2915e56")
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # install project
+ install -d ${pkgdir}/usr/share/webapps/
+ cp -a ${srcdir}/plexwatchweb-git ${pkgdir}/usr/share/webapps/plexWatchWeb
+
+ # install apache config file
+ install -d ${pkgdir}/etc/webapps/plexWatchWeb
+ install -m 644 ${srcdir}/apache.example.conf ${pkgdir}/etc/webapps/plexWatchWeb/
+
+ find ${pkgdir}/usr/share/webapps/plexWatchWeb -type f -exec chmod 0644 {} \;
+ find ${pkgdir}/usr/share/webapps/plexWatchWeb -type d -exec chmod 0755 {} \;
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..f638042874e2
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,18 @@
+<IfModule mod_alias.c>
+ Alias /plexWatchWeb /usr/share/webapps/plexWatchWeb/
+</IfModule>
+
+<Directory /usr/share/webapps/plexWatchWeb/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/plexWatchWeb/:/etc/webapps/plexWatchWeb/:/opt/plexWatch/"
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/plexWatchWeb
+ ServerName plexWatchWeb.foo.com
+ ErrorLog /var/log/httpd/plexWatchWeb.foo.info-error_log
+ CustomLog /var/log/httpd/plexWatchWeb.foo.info-access_log common
+</VirtualHost>