summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2018-12-21 14:31:59 +0000
committerBalló György2018-12-21 14:31:59 +0000
commit9d593f79bd64850306264de5677310b9dbaa745f (patch)
treebd78d72ee613a6c1a482a553173c6d09e8097ec1
downloadaur-9d593f79bd64850306264de5677310b9dbaa745f.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD37
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11a42f22d314
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = plgi
+ pkgdesc = Prolog bindings for GLib/GObject/GIO/GTK+
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://github.com/keriharris/plgi
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = gobject-introspection
+ depends = gobject-introspection-runtime
+ depends = swi-prolog
+ source = plgi-1.0.6.tar.gz::https://github.com/keriharris/plgi/archive/v1.0.6.tar.gz
+ sha256sums = d2e2105acadd0d6752e42304d6a7e1d51025b3c82efdc2a30ca84d402860910d
+
+pkgname = plgi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc2a3ab70fba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=plgi
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Prolog bindings for GLib/GObject/GIO/GTK+"
+arch=(x86_64)
+url="https://github.com/keriharris/plgi"
+license=(LGPL2.1)
+depends=(gobject-introspection-runtime swi-prolog)
+makedepends=(gobject-introspection)
+checkdepends=()
+optdepends=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/keriharris/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('d2e2105acadd0d6752e42304d6a7e1d51025b3c82efdc2a30ca84d402860910d')
+
+prepare() {
+ cd $pkgname-$pkgver
+ autoreconf -fi
+}
+
+build() {
+ cd $pkgname-$pkgver
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $pkgname-$pkgver
+ make -k check || :
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -dm755 "$pkgdir"$(pkg-config --variable=PLBASE swipl)/library
+ make DESTDIR="$pkgdir" install
+}