summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2018-09-24 02:11:57 +1000
committerdaurnimator2018-09-24 02:11:57 +1000
commita6b411349ee8aac5c5acca97904cb10568b098b8 (patch)
tree96f9ef54eef539a51b7b3adc3b5b741c6dcf72e1
parentedcb206e22c6146721744ae7ea110e8c7191cb40 (diff)
downloadaur-a6b411349ee8aac5c5acca97904cb10568b098b8.tar.gz
Use pkgname prefixed tarball to allow a shared SRCDEST
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 81ce594797b8..9e3d7a352deb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = pllua-ng
license = MIT
depends = lua
depends = postgresql
- source = https://github.com/RhodiumToad/pllua-ng/archive/REL_2_0.tar.gz
+ source = pllua-ng-2.0.tar.gz::https://github.com/RhodiumToad/pllua-ng/archive/REL_2_0.tar.gz
md5sums = f4dc3a643513c59a9830ab1ff2e1f07c
pkgname = pllua-ng
diff --git a/PKGBUILD b/PKGBUILD
index 64e0a4ff0c4c..c910a6fcb59f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,26 +2,26 @@
pkgname=pllua-ng
pkgver=2.0
-pkgrel=0
+pkgrel=1
pkgdesc='PL/Lua is a procedural language module for the PostgreSQL database that allows server-side functions to be written in Lua'
arch=('x86_64')
url='https://pllua.github.io/pllua-ng/'
license=('MIT')
depends=('lua' 'postgresql')
-source=("https://github.com/RhodiumToad/pllua-ng/archive/REL_2_0.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/RhodiumToad/pllua-ng/archive/REL_${pkgver/./_}.tar.gz")
md5sums=('f4dc3a643513c59a9830ab1ff2e1f07c')
build() {
- cd pllua-ng-REL_2_0
+ cd "$pkgname-REL_${pkgver/./_}"
make LUA=lua LUAC=luac LUA_INCDIR=/usr/include LUALIB=-llua
make -C hstore LUA=lua LUAC=luac LUA_INCDIR=/usr/include LUALIB=-llua
}
package() {
- cd pllua-ng-REL_2_0
+ cd "$pkgname-REL_${pkgver/./_}"
make DESTDIR="$pkgdir" install
make -C hstore DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}